Category5.TV Community Forum
Migrator - restore from 1.2.3 to 1.3 error - Printable Version

+- Category5.TV Community Forum (https://forum.category5.tv)
+-- Forum: NEMS - Nagios Enterprise Monitoring Server (https://forum.category5.tv/forum-8.html)
+--- Forum: Help and Support (https://forum.category5.tv/forum-9.html)
+--- Thread: Migrator - restore from 1.2.3 to 1.3 error (/thread-106.html)



Migrator - restore from 1.2.3 to 1.3 error - JatBee - 11-11-2017

Just pulled down 1.3, and giving it a spin - long time user of earlier versions.

Installed like a champ, and am trying the "beta" migrator.

Does not seem to get too far. I have a 1.2.3 backup (although I tried a few) that yields the following:

[email protected]:/mnt $ sudo nems-restore /mnt/x.nems
/usr/local/bin/nems-restore: line 175: syntax error near unexpected token `else'
/usr/local/bin/nems-restore: line 175: `                else'
[email protected]:/mnt $

I'm just starting to dig into this, but if anyone has already worked it out let me know. I'll post anything of interest here.

Jim


RE: Migrator - restore from 1.2.3 to 1.3 error - Kuesco - 11-12-2017

Hii, same trouble here. Running 1.3 trying to restore from 1.2.3.

Same exact error so this could not be an isolated case.

Regards.


RE: Migrator - restore from 1.2.3 to 1.3 error - Robbie Ferguson - 11-13-2017

Let me issue a patch this afternoon and check in again. Thanks for reporting this. Been slow going getting Migrator merged over to 1.3 since we hit the SSL issues. Now that is resolved I can look at this for you.


RE: Migrator - restore from 1.2.3 to 1.3 error - Robbie Ferguson - 11-13-2017

Patched.

Please run a sudo nems-quickfix and then try running your nems-restore again.

Please report your experience here so I know if you need anything else.


RE: Migrator - restore from 1.2.3 to 1.3 error - JatBee - 11-13-2017

Config imported!!!

Looks like I may have a few other things to dig into - but that definitely did the trick.

thanks

JayBee


RE: Migrator - restore from 1.2.3 to 1.3 error - Robbie Ferguson - 11-14-2017

Excellent, thanks for confirming. Let me know if you need anything else or encounter any issues I can resolve.