Category5.TV Community Forum
Nagios Graphs not working (Odroid XU4) - Printable Version

+- Category5.TV Community Forum (https://forum.category5.tv)
+-- Forum: NEMS - Nagios Enterprise Monitoring Server (https://forum.category5.tv/forum-8.html)
+--- Forum: Bug Reports (https://forum.category5.tv/forum-38.html)
+--- Thread: Nagios Graphs not working (Odroid XU4) (/thread-480.html)



Nagios Graphs not working (Odroid XU4) - Toxic - 03-25-2019

When I goto the Reporting menau and Select Nagios Graphs i get the following error:


Code:
No data in rrd directory /usr/local/nagios/nagiosgraph/var/rrd


is there something I need to do to get the graphs created or is there something broken with my Install?

that folder is definitely empty. the one above it has two log files:

nagiosgraph.log = 0 bytes

nagiosgraph-cgi.log

Code:
Tue Mar 19 11:07:15 2019 show.cgi 11672 critical No data in rrd directory /usr/local/nagios/nagiosgraph/var/rrd
Sun Mar 24 20:02:56 2019 show.cgi 12200 critical No data in rrd directory /usr/local/nagios/nagiosgraph/var/rrd
Sun Mar 24 20:03:09 2019 showhost.cgi 12246 critical No data in rrd directory /usr/local/nagios/nagiosgraph/var/rrd
Sun Mar 24 20:03:21 2019 show.cgi 12254 critical No data in rrd directory /usr/local/nagios/nagiosgraph/var/rrd
Sun Mar 24 20:03:56 2019 show.cgi 12627 critical No data in rrd directory /usr/local/nagios/nagiosgraph/var/rrd
Sun Mar 24 20:06:02 2019 show.cgi 12936 critical No data in rrd directory /usr/local/nagios/nagiosgraph/var/rrd
Sun Mar 24 20:55:11 2019 show.cgi 20037 critical No data in rrd directory /usr/local/nagios/nagiosgraph/var/rrd
Sun Mar 24 20:56:30 2019 show.cgi 20188 critical No data in rrd directory /usr/local/nagios/nagiosgraph/var/rrd
Sun Mar 24 20:56:33 2019 showhost.cgi 20189 critical No data in rrd directory /usr/local/nagios/nagiosgraph/var/rrd
Sun Mar 24 20:56:42 2019 showgroup.cgi 20193 critical No data in rrd directory /usr/local/nagios/nagiosgraph/var/rrd
Sun Mar 24 20:56:46 2019 showservice.cgi 20194 critical No data in rrd directory /usr/local/nagios/nagiosgraph/var/rrd
Mon Mar 25 20:46:41 2019 show.cgi 31323 critical No data in rrd directory /usr/local/nagios/nagiosgraph/var/rrd




RE: Nagios Graphs not working (Odroid XU4) - Robbie Ferguson - 03-25-2019

Is this NEMS 1.5 Build 3?


RE: Nagios Graphs not working (Odroid XU4) - Toxic - 03-25-2019

yes thats correct with Patch 1 applied

I can reinstall if needed.


RE: Nagios Graphs not working (Odroid XU4) - Robbie Ferguson - 04-01-2019

Okay thanks. I will expedite the release of Build 4 to move XU4 over to the upgraded version. Please watch the site or ping me for an update.