Hello There, Guest! Login Register
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Changing Hostname breaks web access

I wasn't sure if this was intentional behavior or not. But what I did was change the hostname for NEMS to match my naming schema. Just like the rest of my Raspberry Pis, I change the hostname in /etc/hostname. When I done this and rebooted the NEMS web page does not launch. This isn't a DNS issue as I can't even reach the web page by the IP I set. I reverted back to "NEMS" and it's all working.

Just checking to see if this is intended behavior based off of how NEMS works.
Strange. No, this is not intended behavior. You should be able to set your hostname if you want (and know how). My first guess would have been that the hostname is being cached by the avahi-daemon, but you say you can't even reach it by IP.

Can you SSH to it (eg., Apache is down, but server itself is up)? If not, are you certain the hostname was set correctly?

I'd recommend instead trying changing your hostname via Webmin since NEMS is built with the intent of eliminating the need for terminal (other than for the initialization process, for now).

I'd need to know more to help with this. If you can't SSH to it, can you try booting while connected to a TV so you can see what the output says? See if there are any errors on screen?

We'll figure it out together :)

Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
I think I am going to chalk this up to having to not only update /etc/hostname, but also /etc/hosts. I thought in the past all I had to do was update hostname. But then I saw /etc/hosts had the old entry. I probably used raspi-config and never thought of /etc/hosts. What's interesting is that even after a reboot it still failed to load. I checked the services and apache2 wasn't started. I then tried to start apache2 and it started. Just to make sure it held, I did another reboot and all appears to be good.

Thanks for confirming that we can change the hostnames, it helped me make sure to check my side here.
Perhaps go the Webmin route next time just to be sure, rather than editing files directly. Of course, you can edit the files to change hostname, I just don't want to confuse new users who join the forum looking for help and find "Oh, I have to edit /etc/hosts?" - which is not the case. Use Webmin :D

Glad it worked for you!! Enjoy NEMS, and be sure to let me know if there's anything I can do to make it even better for you.

Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
Forum Jump:

Users browsing this thread: 1 Guest(s)