Hello There, Guest! Login Register
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Caught SIGTERM, shutting down

#1
Hi Robbie,

I really like the features and ease of use in 1.4.1.

An interesting issue I noticed is that every so often, when using Nagios Core, the page refresh would not work. I would receive a message "Error: Could not read host and service status information!".

When looking at the Nagios Core Alert History log I noticed the message "Caught SIGTERM, shutting down..." is logged every five minutes and during the 15 or so seconds later the message "Nagios 4.3.4 starting... " is logged, then refreshes work. So if a refresh occurs in the 15 second window, you get the error message.

Attached are screen shots documenting the issue.  I know you are busy with other flavors of NEMS, but wanted to document what I was seeing.

Thanks again for a great upgrade.

Rick


Attached Files Thumbnail(s)
               
Rick
 Reply
#2
How interesting. This sounds like a bug with the monit config. I will look into it!

When you open Monit from the NEMS Dashboard, can you see Nagios as running?

PS - I'm glad to hear you're enjoying NEMS 1.4.1!! Thanks for the compliments. :)

Robbie
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#3
Bug confirmed. I've connected to @ronjohntaylor 's NEMS server (Thanks Ron for giving me access so I can see a live NEMS server "in the wild"!) and can see that after 5 minutes, Nagios indeed receives a SIGTERM.

I stopped the monit service and watched the logs, and the SIGTERM happened again after 5 minutes, so the problem is not monit.

I'll continue investigating and hope to issue a patch this afternoon.

Great find - thank you!
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#4
Ohmigosh - found it!

It's Migrator running the backup. It's stopping Nagios to backup the configs, and then restarting it!

I'm going to have to think this through :) For now, I'll issue a patch that leaves Nagios running even during the backup, and will do some testing to ensure backup integrity.

Thanks again,
Robbie
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#5
Patch issued. Either run: sudo nems-quickfix
Or wait 24 hours for your system to receive the update.
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#6
Thanks Robbie.  Your support is nothing short of amazing. I am putting you in for a raise. Wink

Rick
Rick
 Reply
#7
Ha - thanks! Just don't base it on percentage okay? :D
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
 
 
Forum Jump:

Users browsing this thread: 1 Guest(s)