Hello There, Guest! Login Register
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Contact Groups

#1
Hi,

I might well be being dense, but I can't seem to get Contact Groups to work correctly?

So I've got everything set up on my NEMs system, and I now want other people to get notifications for certain hosts. So I've added the contacts & added them into contact groups.

I've then added the contact groups to certain hosts.

So far so good.

Issue is that only the admin (me) is getting notifications.

At first I thought it was the service settings, as there were some services that had the admin contact group in it & some were blank, so I have removed the admin group from all services so that they should get the contact information from the host, but it is still not sending emails to everyone.

And when I look in Adagios at the hosts I can see all the contact groups against them but the services are still only showing the main admin user.

Any ideas? Do I have to add each group explicitly to each service? Surely that will mean contacts would get notifications for hosts that they are not responsible for as the services are shared over hosts?
 Reply
#2
Hi garethw

Please check in the contacts if you have set the "service notification" "host notification commands" and "notification period" correctly.

Service notification Period: 24x7
Host  Notification options: d,u,r,f
Service Notification options: w,u,c,r,f
host Notification commands: notify-host-by-email
Service Notifcation commands: notify-host-by-email



Greetings

Levin Premium
Model : Raspberry Pi 3 +
Version : 1.5
Build : 6
 Reply
#3
Yes, that's all set correctly.

And if I send a custom notification for a host it gets to everyone, it's just the services that aren't working when it comes to sending notifications
 Reply
#4
Also if I look at the host details in Adagios, I can see "is a member of contactgroups" has the correct contact groups in it, however if I then look at one of the services for that host it only has the main admins contact group associated - even though I have removed all contactgroups from all services!
 Reply
 
 
Forum Jump:

Users browsing this thread: 1 Guest(s)