Hello There, Guest! Login Register
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Contact Groups

#1
Hi,

I might well be being dense, but I can't seem to get Contact Groups to work correctly?

So I've got everything set up on my NEMs system, and I now want other people to get notifications for certain hosts. So I've added the contacts & added them into contact groups.

I've then added the contact groups to certain hosts.

So far so good.

Issue is that only the admin (me) is getting notifications.

At first I thought it was the service settings, as there were some services that had the admin contact group in it & some were blank, so I have removed the admin group from all services so that they should get the contact information from the host, but it is still not sending emails to everyone.

And when I look in Adagios at the hosts I can see all the contact groups against them but the services are still only showing the main admin user.

Any ideas? Do I have to add each group explicitly to each service? Surely that will mean contacts would get notifications for hosts that they are not responsible for as the services are shared over hosts?
 Reply
#2
Hi garethw

Please check in the contacts if you have set the "service notification" "host notification commands" and "notification period" correctly.

Service notification Period: 24x7
Host  Notification options: d,u,r,f
Service Notification options: w,u,c,r,f
host Notification commands: notify-host-by-email
Service Notifcation commands: notify-host-by-email



Greetings

Levin Premium
Model : Raspberry Pi 3 +
Version : 1.5
Build : 6
 Reply
#3
Yes, that's all set correctly.

And if I send a custom notification for a host it gets to everyone, it's just the services that aren't working when it comes to sending notifications
 Reply
#4
Also if I look at the host details in Adagios, I can see "is a member of contactgroups" has the correct contact groups in it, however if I then look at one of the services for that host it only has the main admins contact group associated - even though I have removed all contactgroups from all services!
 Reply
#5
So no one able to offer help with this?
 Reply
#6
I will attempt to test this in the next couple of days.
I am still trying to get notifications from this forum to work consistently.
Thanks all,

Marshman  NY, USA
 Reply
#7
Hi garethw,

I just tested on my Pine64LTS and it works for me. Is it safe for me to assume the other Contacts you have setup use the same mail domain as the Admin for example gmail, Outlook mail etc? I ask becuse my admin is gmail and I would like to use an outlook.com for a second notification but there is no place to add the mail server info. Therefore all Contacts need to be on the same mail domain.
If this is your setup, please let me know which platform you are using, Raspberry Pi Odroid XU4 etc. so I can test further.
Thanks all,

Marshman  NY, USA
 Reply
#8
Hi Marshman,

Thanks for testing this.

Yes, all the email addresses are on the same domain, and all receive emails from the sending account without problems - and when I test the email send it does work, it's just the services that doesn't send the notifications to anyone but me.

It's NEMS 1.5 on a Raspberry PI.

The services themselves don't have any contact groups associated with them, as I believe they inherit from the parent host which does have contact groups assigned - or is that incorrect?
 Reply
#9
I will test on the RPi and see what I can find.
Thanks all,

Marshman  NY, USA
 Reply
#10
garethw,

On my RPi3B I setup a new Contactgroup and gave it a random name.
I then created a new Contact with its own email address ensuring the contact had a 24x7 notification period and all notification options and added that contact to the new Contactgroup.
I then added the new contactgroup to one of my hosts and forced the host to go offline. The new contact received the notification email that the Host was offline. I also added the admin contact to that particular host and BOTH contacts received notifications.

Hopefully, this is the setup you are looking to duplicate.
Thanks all,

Marshman  NY, USA
 Reply
 
 
Forum Jump:

Users browsing this thread: 2 Guest(s)