Category5.TV Community Forum

Full Version: Migrator - restore from 1.2.3 to 1.3 error
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Just pulled down 1.3, and giving it a spin - long time user of earlier versions.

Installed like a champ, and am trying the "beta" migrator.

Does not seem to get too far. I have a 1.2.3 backup (although I tried a few) that yields the following:

[email protected]:/mnt $ sudo nems-restore /mnt/x.nems
/usr/local/bin/nems-restore: line 175: syntax error near unexpected token `else'
/usr/local/bin/nems-restore: line 175: `                else'
[email protected]:/mnt $

I'm just starting to dig into this, but if anyone has already worked it out let me know. I'll post anything of interest here.

Jim
Hii, same trouble here. Running 1.3 trying to restore from 1.2.3.

Same exact error so this could not be an isolated case.

Regards.
Let me issue a patch this afternoon and check in again. Thanks for reporting this. Been slow going getting Migrator merged over to 1.3 since we hit the SSL issues. Now that is resolved I can look at this for you.
Patched.

Please run a sudo nems-quickfix and then try running your nems-restore again.

Please report your experience here so I know if you need anything else.
Config imported!!!

Looks like I may have a few other things to dig into - but that definitely did the trick.

thanks

JayBee
Excellent, thanks for confirming. Let me know if you need anything else or encounter any issues I can resolve.