Category5.TV Community Forum

Full Version: sendemail ERROR => You must specify a 'from' field! Try --help.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7
been banging my head for days on this one.
using gmail to send email, successfully ran the nems-mailtest without issue, email is sent and properly received at the destination.

however i'm getting zero emails from nagios. the closest clue i get is:
Dec 19 22:57:32 nems sendemail[14155]: ERROR => You must specify a 'from' field! Try --help.

this happens when i FORCE a custom notification. it also shows in the logs repeatedly as if every time it tries to send a standard notification it fails with the same error.

current /etc/nagios3/commands.cfg:

define command{
command_name notify-host-by-email
command_line /usr/bin/printf "%b%b%b%b%b%b%b" \
"***** Nagios *****\n\n" \
"Notification Type: $NOTIFICATIONTYPE$\n" \
"Host: $HOSTNAME$\n" \
"State: $HOSTSTATE$\n" \
"Address: $HOSTADDRESS$\n" \
"Info: $HOSTOUTPUT$\n\n" \
"Date/Time: $LONGDATETIME$\n" \
| /usr/bin/sendemail -v -f -s $USER7$ -xu $USER9$ -xp $USER10$ \
-l /var/log/sendemail \

define command{
command_name notify-service-by-email
command_line /usr/bin/printf "%b%b%b%b%b%b%b%b%b" \
"***** Nagios *****\n\n" \
"Notification Type: $NOTIFICATIONTYPE$\n\n" \
"Service: $SERVICEDESC$\n" \
"Host: $HOSTALIAS$\n" \
"Address: $HOSTADDRESS$\n" \
"State: $SERVICESTATE$\n\n" \
"Date/Time: $LONGDATETIME$\n\n" \
"Additional Info:\n\n" \
| /usr/bin/sendemail -v -f -s $USER7$ -xu $USER9$ -xp $USER10$ \
-l /var/log/sendemail \

Note that in the above, I have also tried $USER5$ as the -f configured parameter. No good. I added -v in my attempts to get more verbose output, but this also seems to have made no change.

At a loss at this point.
Thanks. Don't bang your head too hard - your message confirms this must be a bug. I'm not sure how/when it crept up yet, but I'll begin investigating. With the coming Christmas/New Year holidays, I will hopefully have a bit of extra time to sit at the laptop.

Thanks for letting me know. I'll try to roll out a fix as soon as possible.
I just tested on my own server and all is well... so I've got to find the difference between yours and mine. Can you please email me a current backup.nems file?

Thanks. I don't know if this is the cause of your issue, but worth fixing anyways... as NEMS SST says, you cannot have the same email set as recipient as you have for the sender. However, your config shows you have entered the same for both send and receive.

Please change that first, and then retry, and let me know. Again, I doubt it's related, but let's rule that out, just to be sure.
hm, not sure how to do this.

currently in nagios, the alert address (toSmile is different than the from: email set in the NEMS SST.

In the NEMS SST itself, I only see "from" and "authentication" addresses, those are the same, which makes sense to me. I don't see another "TO:" field. What am I looking for to change?

Ah yes, my mistake. Please ignore the man behind the curtain  Smile

I'll review a little closer and let you know what I find.

I had the same problem.

After I rebooted the complete Rasperry Pi, the problem where resolved.

Im also running into this issue cant send emails and have the same msg in my debug logs. What was done to resolve? Thanks!

I've tested the sendmail script and Im able to send emails fine its just not working when valid service check failures occur. 

nems sendemail[20246]: ERROR => You must specify a 'from' field!  Try --help.
This issue has been added to the top of the issues list. See

Will be releasing a patch soon.
Pages: 1 2 3 4 5 6 7