Category5.TV Community Forum

Full Version: Moving to 1.4 and issues I have come across
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6
Moving to 1.4 was relatively straight forward but there were a few "Bugs".  
Robbie has done a HUGE amount of work here and I thank him for his dedication and efforts.
Shy

I will detail some of the things that I found.

  1. nems-mailtest did not work but is now fixed
  2. NRPE did not work but is now fixed
Just run nems-quickfix and both these should be patched.

There are some bugs that are still there.

In Nagios Core:

If you click on Host Detail or Service detail and this error results. (see attachment Nagios Error 1.jpg)

Not Found 
The requested URL /nagios3/cgi-bin/status.cgi was not found on this server.

NEMS_Linux/1.4 Server at 10.0.0.32 Port 80 

RPi Monitor

This seems to have some quirks.  Sometimes it works and other times it does not.  I have found that if I run MonitorIX first it then works.  Weird!
There is also an error on the CPU frequencies that says they are undefinedMHz. (See Attachment RPi Monitor).

Adagios
This looks really interesting but what is it's function and how do we use it?  
When NRPE services were not working I tried to acknowledge them so that they did not keep sending me emails but it did not seem to work.  
Maybe I just don't know how to drive it?

Anyway, apart from the above, I think my NEMS 1.4 is mostly working for me.

Thanks again to Robbie's effort.
Great job!

Ron
Thanks so much for the always thorough report Ron!

1) the fixes you state do not require a nems-quickfix. I'll explain how nems-quickfix works briefly, as I know you'll be interested: By its nature running nems-quickfix is ... a quickfix. That's a command I'll have you run when I first add a patch to expedite its delivery to your NEMS server. However, within 24 hours of my issuing a patch, it will have already been pushed out to all other NEMS servers, negating the need for them to run the quickfix. When you report a bug and I patch it, the reason I have you run nems-quickfix is simply so you don't have to wait 24 hours for the patch to self-install.

2) that is very curious about Nagios pointing to /nagios3/'s version of status.cgi. Very curious indeed. I've grepped through the theme (found at /var/www/html/share/nagios/) and can see that it points to /nagios/ - so I'm going to have to dig into it further. This may be something internal or perhaps in your nagios.cfg file. Can you check that for me?

grep "nagios3" /usr/local/nagios/etc/nagios.cfg
and possibly also check
grep "nagios3" /usr/local/nagios/etc/cgi.cfg
heck... you could scan the whole folder
sudo grep -R "nagios3" /usr/local/nagios/etc/

Any results?

It could be something that got transferred over from the backup from NEMS 1.3.1... a setting from your old server that didn't get converted when NEMS Migrator upgraded the files to NEMS 1.4 format. Surely, once we spot the issue, it'll be an easy fix.

3) RPi-Monitor - thanks, I'll have a look.

4) Adagios is going to be the replacement for Check_MK Multisite. It's still young and probably could be hidden from the menu for now, but I wanted users to see what's coming. For now, Nagios Core will be more reliable, but Adagios will become a more streamlined interface for NEMS users (with its nice mobile-responsive theme and easy user interface). I will find a way to make it more obvious that Adagios' integration is in its early stages, and not all features work yet. I'll be working on patches for Adagios in the coming months, and it will fast become the go-to interface. As you can see, it is quite beautiful.

Thanks again!
Robbie
I've issued a patch that fixes your RPi-Monitor CPU Frequency reporting. Please run sudo nems-quickfix :D
I have confirmed the 404 error you are experiencing appears specific to you, Ron... perhaps something to do with your backup, or some other thing local to your NEMS Server (I do not experience it on mine, even after restoring a NEMS 1.3.1 backup).

Can I SSH in and have a look?
Dude -- just checked and you still had SSH running from our previous session - thanks.

Save yourself some troubleshooting and CLEAR YOUR CACHE  Tongue  The problem you're having seems to be nothing but your browser having cached your old NEMS server links.

I brought up your Nagios Core and clicked the Host Detail and it loaded perfectly from the correct folder. See attached.

Anything else you need, just let me know.
Thanks for taking the time Robbie.
I appreciate the respect you give me and others users. Shy

Grepping Results.....
I have replace username with xxxx for security reasons but I am sure you get that.

[email protected]:~ $ grep "nagios3" /usr/local/nagios/etc/nagios.cfg

[email protected]:~ $ grep "nagios3" /usr/local/nagios/etc/cgi.cfg
[email protected]:~ $ sudo grep -R "nagios3" /usr/local/nagios/etc/
[sudo] password for xxxx
/usr/local/nagios/etc/resource.cfg:$USER2$=/usr/share/nagios3/plugins/eventhandlers

My Impressions of  1.4 so far?
IMPRESSIVE!
I have added an attachment of MonitorIX screendump and it's ticking along nicely on my RPi3+

I have added a few comments in the Thread on SNMP on how I have been exploring SNMP how to use snmp-MIB loader with NEMS.
I realise that this is low on the priority list but having OID's interpreted in HUMAN format will be worth the slog!
Anyway just thought I would throw it in so as to keep the pot boiling...

Adagios
Ah .. Now I understand.  I thought as much but now I know for sure.  Thanks for explaining.
It actually looks really cool.
It will be a nice interface when it's fully fledged.

Cheers
Ron
Wow, Ron. I'm over-joyed to see your Monitorix graphs. That kind of utilization optimization.... WOW. I mean... I'm so proud! THEY SAID IT COULDN'T BE DONE! That's a Raspberry Pi for goodness sake! Just ... wow.

Side note, I imagine my patch this morning fixed your issue in RPi-Monitor?

Thanks for the update!
Robbie
Hey Robbie,
Yep on a RPi! GREAT STUFF MAN!  I think I can still hear your Yahoos from here!! Smile 

Did the Grep's results enlighten you any?

RPi Monitor  
There is still something weird about it.

Just now I brought up the NEMS front end, select RPi Monitor and it worked in a millisecond.
Dropped out that tab and tried to bring it up again and spinning wheels on tab (http://nemsIP address:8888) until chrome times out.
This also dropped out the main NEMS TAB into NEMS so that I had to re-establish the browser session 
Now I click on monitorIX, it comes up straight away, click on RPi Monitor and it comes up straight away.
Weird!
I have added an attachment which still show undefinedMHz in CPU on RPi Monitor.
Anyway, it's not a biggy, I am just dotting "i" and crossing "t's"
Cheers
Ron
Ah, I see. Please run sudo nems-quickfix and then try:
sudo systemctl restart rpimonitor

Does that fix it?
Well Partially. 

Firstly I clicked on RPi Monitor and it came up instantly.
Dropped tab out and brought it up again and spinning wheels on tab.
Dropped out complete session and started again

I got attachment Rpi Monitor 3

Clicked on Status and got attachment RPi Monitor 4 which now has realistic frequencies & voltage.

So I am guessing it's something to do with caching but I really have not got the foggiest  Undecided
Pages: 1 2 3 4 5 6