Category5.TV Community Forum

Full Version: Scheduling Downtime
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
Hi Robbie,

Thought I would update thread so that you would have results when you are ready to jump back in....

Tried the following.

  1. sudo reboot
    NEMS came up but not a lot worked???
    Even SSH session was unresponsive and was connected.

  2. Only thing left to do was Cold Boot
    Did this and all came back but Adagios still as before with zero hosts & services. 
NEMS has been very stable up to this point so don't know what was going on with reboot.

Enjoy your night & get a good night's rest.

Hi Ron,
Sounds like the "reboot" issue you encountered was just a timing thing. On boot, NEMS does a lot of work. So if you try to SSH into it immediately after booting, it can be a bit laggy. Hard to know without seeing your support.nems file. But unrelated to anything I did today so we'll move on :)

I'm interested in why your Adagios is showing no hosts. Did you do anything to try to get Adagios working yourself? Eg., did you edit files in /var/www/adagios or /etc/adagios ?

I ask, because obviously that's a variable I cannot account for, and could explain why you'd be having an issue that doesn't occur on a stock NEMS 1.4.1 (I tested against two systems to be sure).

I'd be happy to remote in and take a look this week to see what's different / happening, and fix it. It's always possible I overlooked something ... but I'm sure it'll be a simple fix.

Hi Robbie,

No I have not made any modifications/edits/play

It's stock standard as far as I know.

I made a conscience decision NOT to do any of that as I knew that this does upset what you are doing and my agenda is to assist where I can and that, now I know, is counter productive.

You are more than welcome to remote in, I am assuming that you still have the details.  They have not changed.
Let me know if you want them again.

I have not run the updated migrator so don't know if that is relevant. I decided that as I was not seeming to have any problems I would put it off for the time being.
In other words "if it aint broke don't fix it...." just for the moment.


2 hrs later. 14:00 EST Aust

I decided to test Nagios -> downtime
See attachment.
It looks like Nagios works works but Adagios does not.
Thanks Ron.
Yeah, I fixed both Nagios Core and Adagios. As long as one or the other work, you're not dead in the water. So now it's just for me to figure out why your particular Adagios install is not seeing your configs. I'll check it out today for you.

Re. Migrator - you'll want to do that sometime because the new update adds a bunch of extra check_commands and advanced_services. You won't have access to them until you re-import your backup.nems file.

Hi Ron,
All set:


So, once again, you've simply revealed that I can't possibly plan for every scenario - LOL.

The issue is that you had renamed your admin contact in NEMS NConf, so it no longer matched your NEMS user. So logging into NEMS Adagios as the NEMS user, you wouldn't see any of the hosts as your hosts are all under a different user.

I've removed that restriction from your server, and will work on a permanent fix to push out to everyone else.


I've rolled out the fix to nems-update.

Thanks again for the report, Ron.

Stay away from the Adagios configuration options... they're included by default and now that I've opened up "admin" access to it, they'll show. But of course NEMS is administered by NConf - so I have to decide how I want to remove the configuration tasks from Adagios (as I think NConf is better for this with all the improvements I've made over the years).
Good Morning Robbie,

Sorry for late reply this morning but have email issues with my bigpond account. 
Still unresolved.
Thanks for your help once again.
Glad I was able to highlight and issue for you.

I have quickly checked and Adagios seems to be working as it was but have not done ant testing with downtime etc.

Thanks for the tip about config.  I always had used NConf but had wondered if it was they new way but now I know I will continue to use NConf.

Need to get email back up for family and working with ISP is not easy.

K man. Hopefully they get that issue fixed for you quickly.

In the meantime, I am confident your Adagios is working now for scheduling downtime and acknowledging outages.

I'll work on removing the extraneous "config" options as soon as is possible.

Hey Robbie,
Resolved ISP issues with email.  Someone tried to hack my account so they suspended it.  I had to jump some hoops but all sorted now.
Luckily I still had my GMail account to use.

I have tested Adagios for scheduling downtime and all good. I am sure the Acknowledgement of outages will work now as well.

1.4 is really looking good now.

Well Done man!

Hope I can continue to be of help to you with trouble shooting.

Thanks Ron! NEMS keeps getting better and better! It's exciting being part of such an active and useful project.

Glad I was able to sort this one out for you and the rest of the NEMS users! More work will go into the Adagios interface in future, but it is quite functional now.

Be well!
Pages: 1 2 3