Category5.TV Community Forum

Full Version: Connecting to plexpi using RealVNC
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all

I installed Plex on a RasPi 3B+ yesterday. This is my 2nd Pi and I control them headlessly. The PlexPi is working as it should and I can connect to it using "plexpi:32400/web" from my PC's browser. Today I have installed a VNC server on the Pi and RealVNC viewer on my PC in the hope that a GUI would be a little more user friendly than an SSH terminal window.

This has worked fine with one problem - connecting to the Pi with the VNC viewer brings up Plex running full screen on the Pi. Not being familiar with the Pi's graphical desktop I'm wondering if it's possible to minimise the Plex application to use the GUI beneath. When starting the VNC session I briefly see the graphical desktop before Plex takes up the full screen. Alt-Tab just pops up a notification of "Plex - Chromium" but doesn't allow switching to the desktop. Is this possible?
OK peeps - found it. Alt-F4  Blush
How did you get the server running?
(07-25-2018, 12:19 PM)FirebladeRunner Wrote: [ -> ]OK peeps - found it. Alt-F4  Blush

That does the trick! Sorry I wasn't around to reply to you earlier.

Every time I restart my PlexPi, I have to VNC into it in order to press Alt+F4 and get the full screen window down.
As Robbie was saying, if you're having to shut down the full screen window, then PlexPi is not really being used as intended. I agree to a certain extent. I like to run sudo apt-get update and upgrade every once in a while. Although, with SSH enabled, you can do that remotely without the need for a GUI.
How do you get the vnc server started?
RealVNC is installed by default, so look for the app (normally in the top right corner of your menu bar) and set up an account.

Make sure VNC is enabled in the Raspberry Pi configuration panel.
This is how I've addressed this issue:

Code:
sudo crontab -e

in the text editor that opens, add this


Code:
@reboot /bin/sleep 60 && sudo killall chromium-browser > /dev/null 2>&1


hit Control-O and then Control-X and you're done.

This automatically kills the plex full screen kiosk after 1 minute of the startup.

Enjoy!