Category5.TV Community Forum

Full Version: Nems - Nagios Core not started.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I tried to post this a couple of days ago. In Australia the government is rolling out then National Broadband Network(NBN), it should be renamed No Bloody Network.Since I have changed over to it, I have had more internet outages in one day(minimum 4 times a day) than I had the whole time under my old cable connection. So I had just finished my post 2 times and as I went to post it, I lost my internet connection.

Any I am having another go.

Every time I go into Nems - Nagio Core, I get the following:-


Error: Could not read host and service status information!

The most common cause of this error message (especially for new users), is the fact that Nagios is not actually running. If Nagios is indeed not running, this is a normal error message. It simply indicates that the CGIs could not obtain the current status of hosts and services that are being monitored. If you've just installed things, make sure you read the documentation on starting Nagios.

Some other things you should check in order to resolve this error include:

  1. Check the Nagios log file for messages relating to startup or status data errors.
  2. Always verify configuration options using the -v command-line option before starting or restarting Nagios!
Everything was working OK up until about a wek ago and then I started to get above message.

I have checked everything I can think of with little success. Some of this I am not sure of where in Nems I find. Any advice will be appreciated.

Argh, those dang cockatoos chewing up the Internet cables! :P

Sorry you're having trouble. I imagine you have tried rebooting your NEMS server? I reckon this has something to do with your configs. It'd help if I could see.

Can you send a support.nems file for me to review?

Hi Gazza,
Received the file, thank you.

Did you by any chance run a manual dist-upgrade? I ask because it appears some system files are corrupt. This could also mean a bad SD card.

It doesn't look like a NEMS-specific issue, but the underlying OS is having trouble. So re-flashing and importing your backup.nems would be easiest I think. Probably to a new SD card.

It looks like the problem started in October... so it leads me to wonder if your SD card might be failing... just a guess.

Can you let me know what you decide to try and how it goes?

-- as a side thought, when was the last time you rebooted your NEMS server? I just put that out there in case the OS issue is due to an upgraded package that needs a restart or something. Long shot I know, but probably best to reboot to see if it comes ready.
Hi Robbie
               Appart from restoring the NEMS backup I have done no updates to my NEMS 1.4. When the problem first occurred, I shut it down and restarted it from scratch but that made no difference. I read through the Nagios document but didn't do anything it suggested as I wasn't sure of how NEMS would be affected by any Nagios changes. I thought asking on forum was best solution. I will try another SD card and restore backup and see how it goes.

As I said, the unit was running perfectly OK and this happened out of the blue. I am not sure if the problem arose after a power outage which may have damaged the SD card or corrupted the files. We have been having some very nasty electrical storms over here.
Hi Robbie
               Thanks for you help.  It appears that the SD card is corrupted. I have setup a new SD car and restored my backup.nems.  My NEMS appears to be running Ok now.
Great to hear, thanks for the update.
Yes, I could see in your support.nems file that the filesystem was corrupt, which is why I suspected the SD card. Perhaps a UPS is in order if you are having power issues... SD cards are really finicky if you have dirty power, and I'd hate to see you have trouble.