Category5.TV Community Forum

Full Version: [Solved] Check commands not Working (WMI) |
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2

I have the problem if I want to do a check command, he gives me back this error message : 
(No output on stdout) stderr: execvp(/usr/local/nagios/libexec/, ...) failed. errno is 2: No such file or directory

Check Commands i tried:

Its a Windows Server 2012 

When i Check from Windows CMD with this command then it Works:
wmic /node:"IP_Adress from Server" /User:"Username_from_Server" LogicalDisk Where DriveType="3" Get DeviceID,FreeSpace|find /I "c:"

Have someone an Idea ? Thanks !

Update 13.03.2019
Install the latest nems-quickfix. Its Solves the Problem
Hi Premium.
Which version of NEMS Linux, which build, and which platform?
Hi Robbie

Nems Platform RPi 3 Model B
Nems Version: 1.5

I tried now also with NSclient ++. But there I get the error message "Could not Fetch information from Server"
I used NSCLient++ version.

telnet works with Ports 12489 and 5666

Levin | Premium
That's from the NSCLIENT log

2019-03-05 13:37:31: error:c:\source\master\service\plugin_manager.cpp:475: Unknown command(s): check_cpu available commands: commands {, submit_nsca}, plugins {, 1}
2019-03-05 13:39:24: error:c:\source\master\service\plugin_manager.cpp:475: Unknown command(s): check_process available commands: commands {, submit_nsca}, plugins {, 1}
Problem solved

After testing all day today I have new knowledge..

First you have to set everything to enabled in config file.. (C:Program Files/NSCLIENT++/nsclient.ini)
specifically the following: checksystem , CheckDisk, CheckEventlog

Thank you anyway Robbie

P.s But it would still be good if you check the check_win_ * commands, because none of them work
All fail with "failed. errno is 2: No such file or directory"
>> But it would still be good if you check the check_win_ * commands, because none of them work
All fail with "failed. errno is 2: No such file or directory"

What build are you on? This should not be the case in Build 6. That was only a problem in Build 2 which was a pre-release beta. Please confirm?
Hi Robbie

I can not retrieve the build number with the Nems info command. It shows me 1.5 everywhere and no build number
But I looked at the ISO name that I downloaded on 26.02.2019 16:51 CET time. It says "NEMS_v1.5-RPi-Build6".
Have not loaded a backup.

I also ran the nems-update and nems-quickfix commands
Could it be that it is an incorrect setting on the Windows server? Or should I reinstall the Nems again?


Levin | Premium
Yeah, you're right to look at the img file for your build #. That is specifically what I needed to know. Yours is NEMS 1.5 RPi Build 6.

You already solved your NRPE issue (using NRPE check commands but hadn't properly configured NRPE on your Windows server) but the WMIC issue is different (what you have called  check_win_*).

In a NEMS terminal, tell me the output of this command:

ls -lah /usr/local/nagios/libexec/

Also please confirm you have configured WMI on your Windows server.

Hi Robbie

Thats the output from Nems Terminal:
ls: cannot access '/usr/local/nagios/libexec/': No such file or directory

yes, if I check with windows it works


Can you please test it today and tell me if anything has changed since the last update?
Pages: 1 2