Category5.TV Community Forum

Full Version: Getting "index of" page instead of NEMS web UI
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Seems to happen during the update from 1.2.1 to 1.2.2 not sure since it immediately goes to the update to 1.2.3.

I am running 2 systems made from the same .ISO file and it only happened on one of the 2.

I reinstalled and it has the same issue every idea what is causing it.  Huh
Hmm, that's very odd.

It's easy to fix, but I'd very much like to see your NEMS Server if I may so I can determine if this is something specific to you, or if it is a bug with the upgrade script that I need to address.

Please let me know if an SSH connection is possible. If not, I'll just give you some code to fix it.

I've not had this happen on any of my NEMS servers, so seeing your Pi may help me understand how it happened.

Unfortunately, I cannot give you remote access right now but I would highly appreciate the code snippets to fix it.

Thank you.
First, what do you see when you type:

nems-info diskusage

I'm wondering if your card is too small for NEMS ... so that'd tell us.

If the number is less than 50%, it's not that.

If it's not that, this should fix the symptom, but not the cause:

sudo mv /var/www/html /var/www/html.old~ && cd /var/www && sudo git clone && sudo mv nems-www html && sudo chown -R www-data:www-data html && sudo nems-update

I really would like to know why this is happening to this one Pi.
Let me know.
I tried:
nems-info diskusage

It returned 13. makes sense since I am using 32GB cards so I am sure I have plenty of room.

The setup is the exact same as the other NEMS server I have that is working. Raspberry Pi 3, Sandisk 32GB micro SD class 10, even burnt from the same ISO file on the same day on the same windows PC.

As for the results of:
sudo mv /var/www/html /var/www/html.old~ && cd /var/www && sudo git clone && sudo mv nems-www html && sudo chown -R www-data:www-data html && sudo nems-update

I copied and pasted this so there is no errors then waited and rebooted.

Now I still get the index of page but it only shows the backup directory...
Could you kindly repeat the steps again but paste the full output for me?

Sounding like a bad SD card TBH.

- PS - there's no need to reboot (note my inclusion of sudo nems-update at the end... this takes care of everything the reboot would do.)
Problem resolved after Robbie reinstalled nems-www.

Thanks again.