Hello There, Guest! Login Register
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

"ERROR => ERROR => SMTP-AUTH: Authentication to" Turn OFF SMTP auth?

#1
OK... I hate to say this... but...

Last Sunday morning I bit the bullet and went to upgrade to NEMS 1.4 ... unfortunately it sorta blew up in my face and most of the system wasn't functioning correctly. Some of the web interfaces were unreachable, hosts were no longer being checked... etc. So I just decided to do it some other time and rolled back to 1.3. Unfortunately now... it seems to insist on using SMTP authentication to send notifications to my internal mail server... which doesn't need authentication (it's not exposed to the outside world at all). So of course... notification doesn't work.

How do I turn that off? Just good old SMTP plain text...
"You can watch things happen, you can make things happen or you can wonder what the hell just happened." - Captain Phil Harris - Deadliest Catch
 Reply
#2
Smile Well, your experience with 1.4 was not normal. That might have been a bad download, or maybe your browser cache needed clearing due to the old 1.3 being cached.

That said, please explain the issue for your SMTP. Are you seeing the error in NEMS SST? Eg., are you able to leave it blank? Not quite sure what you're explaining, but I want to help.

And by all means, you should try a new download of NEMS 1.4 and make sure you check the MD5 before you burn it.

Cheers,
Robbie
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#3
Oh not to worry... I'll be upgrading for sure! It's just a matter of 'when' and not 'if'.   Smile

When I reloaded I left the fields blank in NEMS SST for SMTP Authentication as I always have. While trying to track down why notifications weren't being sent, I used command line utility for testing it and that's where the error is being shown. I tried setting the fields for authentication in NEMS SST, saved them, then cleared them and saved again. Same result. So I flushed the browser cache and tried again. Same result. I did check to make sure that the device was completely up to date though (nems-update, nems-upgrade).

This isn't a show-stopper by any means and I can always just wait until I can get my hands on a few more micro-SD cards for playing with. That is definitely on my "To do" list.
 Reply
#4
So are you saying your SMTP relay does not use authentication? DANGER WILL ROBINSON!

If you blank the fields in NEMS SST, NEMS will in fact send "null" as the username and password (not blank).

Best thing to do is to enable authentication on your SMTP relay. It is not safe to have it wide open without auth, and I will not support that setup, ever.

Under the hood, the username/password for auth are stored in Nagios' config. That config requires something to be set as the value... hence "null". If it was actually blank, the config would break at that point.

What I mean is, if the configuration is:
[email protected]
password=1234
othersetting=123
That's fine.

So...
email=null
password=null
othersetting=123
is also fine (won't work, but won't error).

However...
email=
password=
othersetting=123
Will result in nagios loading this:
email=password=othersetting=123

Yes, "email" would in fact equal "password=othersetting=123"

So by the very nature of the thing, I must have null in the config when you save an empty field.

Please enable auth on your SMTP server, or use something like Gmail that already supports it.

Cheers,
Robbie
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#5
Well... I appreciate, understand and respect the concern over a non-authenticating SMTP server. However it's in no way exposed to the outside world and frankly if someone (or some thing) were able to exploit it, then I have far FAR bigger problems that would need to be addressed.

But... since the device is being used strictly to monitor my internal gear I'll happily deal with not getting notifications for now until I can complete the project I'm currently planning out and working on. That project is to completely do away with the two Windows servers that make up my internal domain and migrate everything over to two Ubuntu servers. To put it mildly... I'm a bit tired of dealing with Windows on the home network and I'm definitely not big fan of this "Windows 10" thing Confused . But I digress....   Tongue 

Thank you SO much for taking the time to respond to this.
"You can watch things happen, you can make things happen or you can wonder what the hell just happened." - Captain Phil Harris - Deadliest Catch
 Reply
 
 
Forum Jump:

Users browsing this thread: 1 Guest(s)