Category5.TV Community Forum
check_rpi_temperature / nconf / missing critical temperature - Printable Version

+- Category5.TV Community Forum (https://forum.category5.tv)
+-- Forum: NEMS - Nagios Enterprise Monitoring Server (https://forum.category5.tv/forum-8.html)
+--- Forum: Help and Support (https://forum.category5.tv/forum-9.html)
+--- Thread: check_rpi_temperature / nconf / missing critical temperature (/thread-113.html)

Pages: 1 2


check_rpi_temperature / nconf / missing critical temperature - mgl1976 - 12-01-2017

I will use the check_rpi_temperature, i use nconf.
I only have one Arg1 Field under the Service Parameters.
I set the warning temperature there. But where can i set the UNKNOWN - missing critical temperature ??? Dodgy
55,60 doesn`t work ....


RE: check_rpi_temperature / nconf / missing critical temperature - mgl1976 - 12-04-2017

No ideas ? ;-(


RE: check_rpi_temperature / nconf / missing critical temperature - Robbie Ferguson - 12-04-2017

Hi mgl1976,
Thanks for your patience. Been very busy with NEMS 1.4 development + getting things ready for Christmas season (eg., shopping for my kids - haha!)

One of the things I really will be working hard on in the next while is documentation for each check command. You'll notice in the docs I've already setup a spot for it, I just haven't gotten very far with writing them yet.

I'll make this one my priority and will try to document the feature as soon as I can. I also see from your message that perhaps there is something wrong with the check command itself, and I won't rule out that maybe there is - but will do some testing on my end with NEMS 1.3 and push out any fix if necessary.

Watch this page: https://docs.nemslinux.com/check_commands/check_rpi_temperature

I will do my best to write the documentation for check_rpi_temperature as soon as possible (may be a week or two). I will also test it more thoroughly on my end just in case there is a bug.

Thanks!


RE: check_rpi_temperature / nconf / missing critical temperature - mgl1976 - 12-19-2017

I tried a lot of things now...but i still can´t set the UNKNOWN - missing critical temperature....
I´m looking forward to your upcoming Documentation entry for the check_rpi_temperature command Big Grin


RE: check_rpi_temperature / nconf / missing critical temperature - mgl1976 - 01-11-2018

Still no solution ? ;-(


RE: check_rpi_temperature / nconf / missing critical temperature - Robbie Ferguson - 01-12-2018

Sorry - been on break over Christmas/New Year and just now getting back to it.

I have a lot on my plate with all that's being done here, but will look into this for you asap. Priority support is also available through our Patreon page if you need this urgently.

Thanks,
Robbie


RE: check_rpi_temperature / nconf / missing critical temperature - Robbie Ferguson - 01-12-2018

Added to the To Do list.


RE: check_rpi_temperature / nconf / missing critical temperature - CrispyChicken - 10-22-2018

Hi All

I did get his to work earlier this year however I can't remember how i did it.

I vaguely remember editing the 'check_rpi_temperature' command and entering a 55 and 60 value the in the default command paramas.

I have attached a screen shot of mine. This does not work and i know I'm missing something, I think it's how I'm separating the two values just can't remember.

If someone could help out and display how they got warning and critical to work with their chosen values that would be awesome

Cheers


RE: check_rpi_temperature / nconf / missing critical temperature - Robbie Ferguson - 10-22-2018

It's on the list for NEMS 1.5 as well, so hopefully this won't haunt you much longer :)


RE: check_rpi_temperature / nconf / missing critical temperature - Robbie Ferguson - 11-03-2018

check_rpi_temperature has been renamed check_sbc_temperature, and is working great in NEMS 1.5. Make sure you upgrade to NEMS 1.5 when it releases.

See the documentation for more details: https://docs.nemslinux.com/check_commands/check_sbc_temperature