Category5.TV Community Forum
PI Zero W: Headless - Printable Version

+- Category5.TV Community Forum (
+-- Forum: NEMS - Nagios Enterprise Monitoring Server (
+--- Forum: Help and Support (
+--- Thread: PI Zero W: Headless (/thread-280.html)

Pages: 1 2 3

PI Zero W: Headless - t0770 - 07-12-2018


I have written the latest image to my SD - but how can I configuere WiFI Setting? I have added wpa_supplicant.conf to boot but this does not work...

any ideas?


RE: PI Zero W: Headless - Robbie Ferguson - 07-16-2018

Hi Tim,
Then: sudo raspi-config

Anything else you need, please let me know.

RE: PI Zero W: Headless - wpmjones - 07-22-2018

I'm having the same problem.  Fresh install from and wifi isn't working.  I did raspi-config, switched to my country, and entered the correct wifi credentials.  After reboot, ip addr show reveals the following:

wlan0: <No-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
link/ether 5a:be:8d:0a:92:4a brd ff:ff:ff:ff:ff:ff:ff

Wifi works fine if I put a stock version of strech on an SD card on this Pi, so it's definitely something in the image.  I tried lspci and lshw but neither are installed and I can't install them because the device can't see the internet.  dmesg says "link is not ready - power management disabled"

Any thoughts?

RE: PI Zero W: Headless - Robbie Ferguson - 07-22-2018

I haven't experienced this problem with the current 1.4.1 build, but am happy to do some testing to be sure it's working okay (or fix, if not).

So WiFi / Internet was working prior to a reboot?

RE: PI Zero W: Headless - wpmjones - 07-22-2018

Wifi worked on the SD card that was in this Pi prior to NEMS (stock Raspbian Stretch).  I flashed NEMS and wifi has not worked at all under NEMS.

RE: PI Zero W: Headless - Robbie Ferguson - 07-23-2018

You are certain you've entered the correct wifi connection info in raspi-config?

Please send me a copy of your support.nems so I can have a look. Because you cannot get on WiFi, you'll have to be creative about how to get it to me.

I added networking to support.nems so if you're doing this today please first run sudo nems-update

I'd suggest, perhaps: sudo nems-support && sudo cp /var/www/html/backup/snapshot/support.nems /boot

Then plug the SD card into a computer and get the file from the boot partition, following the instructions in nems-support with regards to your decryption string.

Here's hoping! :)

RE: PI Zero W: Headless - Robbie Ferguson - 07-23-2018

Ha, NVM - I'm daft this morning. No Internet = no nems-update.

Can you do the support.nems file anyways, and let me know about what you've done to ensure the correct SSID, etc?

RE: PI Zero W: Headless - JDogg1329 - 07-25-2018

Hi there, I'm having the same problem :Sad can't for the life of me get onto Wifi, I've been troubleshooting for hours. My Wpa_supplicant file looks fine, and wifi is confirmed working on a previous image and SD card

ping returns "Temporary failure in name resolution"

RE: PI Zero W: Headless - Robbie Ferguson - 07-25-2018

Okay thanks. Even though I have not seen this problem yet, I will treat this as a known issue and try to get to the bottom of it asap.

Thanks for letting me know.


RE: PI Zero W: Headless - JDogg1329 - 07-25-2018

No worries mate. I have it running over ethernet (via a usb to ethernet adapter) so if I can help with debugging in any way let me know