Category5.TV Community Forum
No Performance Data From Command - Printable Version

+- Category5.TV Community Forum (https://forum.category5.tv)
+-- Forum: NEMS - Nagios Enterprise Monitoring Server (https://forum.category5.tv/forum-8.html)
+--- Forum: Help and Support (https://forum.category5.tv/forum-9.html)
+--- Thread: No Performance Data From Command (/thread-380.html)



No Performance Data From Command - lee3521 - 11-27-2018

Hi Everyone,
I am currently in the process of testing NEMS linux.  I am currently attempting to monitor several computers.  I am having problems trying to use the check_memory command as it shows up as an error on the TV monitor dashboard.  The machine I am monitoring is a windows 10 pro 64-bit machine running NSClient++ version 0.5.2.35 64-bit.  The error that is being displayed is "NSClient - ERROR: No performance data from command: check_memory"  My NEMS Linux version is 1.4.1 running on a Raspberry Pi 3B+.  Any help would be greatly appreciated.


RE: No Performance Data From Command - Robbie Ferguson - 11-27-2018

Hi lee3521,
There is no default check_memory command, so I'm not sure what you're doing.

Do you mean check_win_mem? That's the closest I have pre-configured. If that is indeed the one you mean, did you enable WMI on the machine?

It'd probably be best to submit your support.nems so I can see what you're actually doing. Otherwise, I'm just guessing. https://docs.nemslinux.com/commands/nems-support

This'll be a configuration issue on your end, and I'm happy to help if I can.

Cheers,
Robbie


RE: No Performance Data From Command - lee3521 - 11-27-2018

Yeah, this is a learning curve for me for sure.

Here are the screen shots of my hosts config along with the TV dashboard.


RE: No Performance Data From Command - infocon - 11-28-2018

Try adding this in your nsclient.ini I ran into similiar situation when testing nsclient++.

; in flight - TODO
[/settings/default]
allowed hosts = 'IPv4-subnet'
bind to = 0.0.0.0