Hello There, Guest! Login Register
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Monitoring Linux Hosts with NRPE (Both NEMS 1.4.1 and 1.5)

I am trying to monitor a Linux Server (Ubuntu 16.40 LTS) via NRPE and having trouble.

I've tried executing the following command to make sure I can run the plugin remotely (SSH'd into my NEMS Server):

/usr/lib/nagios/plugins/check_nrpe -H -c check_root

and I get the following error:

-bash: /usr/lib/nagios/plugins/check_nrpe: Too many levels of symbolic links

I was getting the same error with NEMS 1.4.1 and was unable to resolve.

Any recommendations to resolve this issue?

I was having the same issue with build 2 and build 5 of NEMS 1.5. Build 6 fixed the issue for me. So, make sure you are using the latest version. Hope this info helps you.
OK, moving to build 6 fixed that issue.  Thanks for the recommendation!!!

Now when I run (from my NEMS Server):

/usr/lib/nagios/plugins/check_nrpe -H -c check_root

I get the follow error:  

CHECK_NRPE: Error - Could not connect to Connection reset by peer

In Nagios, it shows:  

CHECK_NRPE: Error - Could not connect to Check system logs on

I enabled the logging option in nrpe.cfg and restarted the service.

When I look at the log file under /usr/local/nagios/var/ it shows the following error:

[1552094679] CONN_CHECK_PEER: checking if host is allowed: port 34029
[1552094679] Connection from port 34029
[1552094679] is_an_allowed_host (AF_INET): is host >< an allowed host ><
[1552094679] is_an_allowed_host (AF_INET): is host >< an allowed host ><
[1552094679] Host is not allowed to talk to us!
[1552094679] Connection from closed.

It seems like check command is using a different port everytime Nagios (or I do via terminal) sends a check.

How do I get nrpe to use only port 5666?

Forum Jump:

Users browsing this thread: 1 Guest(s)