Hello There, Guest! Login Register
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Upgrade to nems 1.5 nagios.service issue

#1
Testing upgrade to nems 1.5 and getting a restore error then failure of nagios livestatus.


Imaged new sd card, backed up existing 1.4.1 instance.
Nems-init on new sd card (same user name used as backup).
Nems-restore the backup.
Everything runs fine through "Consolidation complete." (all the imports appear to have worked).
Then get two lines :
   "Job for nagios.service failed because the control process exited with error code" (yes, that's all, no error code).
   "See "systemctl status nagios.service" and "journalctl -xe" for details."

Looking at systemctl, get this:
\[email protected]:~ $ sudo systemctl status nagios.service
● nagios.service - Nagios Core 4.4.3
   Loaded: loaded (/lib/systemd/system/nagios.service; disabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sat 2019-02-23 10:41:59 MST; 1min 24s ago
     Docs: https://www.nagios.org/documentation
  Process: 16417 ExecStartPre=/usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg (code=exited, status=1/FAILURE)

Feb 23 10:41:59 nems nagios[16417]:      Check your configuration file(s) to ensure that they contain valid
Feb 23 10:41:59 nems nagios[16417]:      directives and data definitions.  If you are upgrading from a previous
Feb 23 10:41:59 nems nagios[16417]:      version of Nagios, you should be aware that some variables/definitions
Feb 23 10:41:59 nems nagios[16417]:      may have been removed or modified in this version.  Make sure to read
Feb 23 10:41:59 nems nagios[16417]:      the HTML documentation regarding the config files, as well as the
Feb 23 10:41:59 nems nagios[16417]:      'Whats New' section to find out what has changed.
Feb 23 10:41:59 nems systemd[1]: nagios.service: Control process exited, code=exited status=1
Feb 23 10:41:59 nems systemd[1]: Failed to start Nagios Core 4.4.3.
Feb 23 10:41:59 nems systemd[1]: nagios.service: Unit entered failed state.
Feb 23 10:41:59 nems systemd[1]: nagios.service: Failed with result 'exit-code'.

When I start the web interface I am able to get to the front end, but going to any of the reporting tools generates "livestatus" errors.

Any assistance would be appreciated, and let me know what I can do to help.

Thanks, Steve
 Reply
 
Messages In This Thread
Upgrade to nems 1.5 nagios.service issue - by hudtheitguy - 02-23-2019, 02:09 PM
RE: Upgrade to nems 1.5 nagios.service issue - by IMBACalimba - 02-23-2019, 04:57 PM
RE: Upgrade to nems 1.5 nagios.service issue - by hudtheitguy - 02-23-2019, 07:29 PM
RE: Upgrade to nems 1.5 nagios.service issue - by hudtheitguy - 02-23-2019, 08:11 PM
RE: Upgrade to nems 1.5 nagios.service issue - by hudtheitguy - 02-24-2019, 06:45 PM
 
Forum Jump:

Users browsing this thread: 1 Guest(s)