Hello There, Guest!  
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

NSClient - ERROR: Invalid password.

#1
I have NEMS 1.3 up and running, and I'm having a little trouble adding my first Windows Server host. I got the server added in NConf, but I'm getting the "NSClient - ERROR: Invalid password." Error in Nagios Core.

I have installed NSClient++ installed and I am able to configure it via it's web interface. The problem is I have no idea which password is not right or where to configure that in the NEMS interface or the NSClient.

Anyone have any ideas?
 Reply
#2
Hi deger. Have you set your Windows administrator login & password in NEMS SST?
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#3
Robbie,

I have, I setup an account for NEMS and made it a member of the administrators group, does the account need higher rights like domain admin? Is there any way to test the credentials I have added?

Thanks,
Dave
 Reply
#4
Hi Dave,
Once you've created the account on your Windows server, you need to open NEMS SST and set the username and password to match.

To access NEMS SST, click Configuration→NEMS System Settings Tool.

Let me know if that helps.
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#5
I have the account credentials in NEMS SST, still no luck, do I need to specify it in the NSClient somewhere?
 Reply
#6
Please review the documentation and let me know if it gets you up and going.

In particular: https://docs.nemslinux.com/usage/nrpe_on_windows

Thanks!
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#7
Sorry to be a pain, but I don't understand 2 things,

If I don't set a password for NSClient during setup, I am unable to log into the NSClient web interface and enable all of the default checks like CPU load and memory usage. How do I turn that on in the NSClient?

The page also mentions that NSClient is not nessacary and to "otherwise use the provided WMIC-based check commands." Where do I find those commands?
 Reply
#8
Anyone running without NSClient and using WMI instead? I'm having trouble finding any documentation on setting that up, although it looks like it is supported.
 Reply
#9
Hi all =)

I am also interested in getting NSclient++ working on multiple windows 10 pc’s and laptops.
  • I have install NSclient++ as per Robbie’s instructions.
  • Now I feel I need to put the password into Nagios somewhere, the one that was generated when NSclient++ was installed.
I have looked at the below website and it suggests editing the commands.cfg file and place the password within the command_name check_nt.

define command{
command_name check_nt
command_line $USER1$/check_nt -H $HOSTADDRESS$ -p 12489 -s PASSWORD -v $ARG1$ $ARG2$
}

The link is below.
https://support.nagios.com/forum/viewtopic.php?t=35386

Cheers
Pete Smith  :shy:
 Reply
#10
Hi Pete,
Those instructions are for Nagios, not NEMS.

In NEMS, you need to go into NConf and add the argument to the check command when you add it to your host.

If you follow the directions you posted, you'll wonder why your configuration no longer works since your checkcommands.cfg file (which you are not supposed to touch on NEMS) is out of sync with NConf's mySQL database.

Cheers,
Robbie
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
 
 
Forum Jump:

Users browsing this thread: 1 Guest(s)