Hello There, Guest!  
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

samba for plex

#1
using v1.2 of plexpi,,,,,,working great thanks........samba would be a great add to the image ,,,,connecting to windows network would enable copying across content to a drive on the pi with ease...
 Reply
#2
Just log in to it and do this with user name pi and password plexpi1

Then sudo su So you can save the smb.conf as root

Then do a apt install samba

Then nano /etc/samba/smb.conf

Got all the way to the end and put this there:

[media]

writeable = yes
comment = All media
path = /media
browseable = yes
public = yes
create mask = 0644
directory mask = 0755
force user = pi

Save it with CTRL W then CTRL X to exit.

restart samba with /etc/init.d/samba restart

Go to //plexpi and it will show all mounted in media folder.

-Raymond Day
 Reply
#3
Hi Raymond,
I had to run sudo apt-get update before installing samba otherwise it was erroring out.

How can I see all my network shares?

Thanks!
 Reply
#4
It's on the roadmap for sure! The reason Samba has not yet been implemented is because I have no control over what you call your drives connected to PlexPi - so it takes some knowledge on your end to map the Samba share correctly. Eventually, I will have PlexPi include a web interface that lets you configure these types of settings.
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#5
Hello, please help me. Ive got plexPi installed working ok but wanted to use the drive as a NAS too so tried installing samba as mentioned here but when i do "nano ec/samba/smb.conf" it says the file doesn't exist? I tried double checking samba installed correctly and it had no issues?

Please help a pi noob out!
Thanks
 Reply
#6
that should be /etc/ not ec/
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#7
I'm getting a "Folder can't be opened because you don't have permission to view its contents" error when I try to access the PlexPi attached USB drive from my Mac. I've tried changing the permissions on the /pi/media directory and drives contained there. I'm pretty green to linux, though I've set up a couple Raspberry Pi's now for home automation and this media server. Any help and extra patience appreciated!
 Reply
#8
I'm having a problem restarting the samba server. Anyone else? Alternatives to connecting to the Pi from a Mac?
 Reply
#9
If you have Linux clients connecting to the PlexPi, install and use sshfs.
Ssh is already running on PlexPi. Once you connect to the PlexPi, you're file manager sees the volume as any old local folder. AND, sshfs can be run as a user, and not as root. It is very convenient.
Just a thought.
 Reply
#10
I'm a bit disappointed. In the YouTube video you said this was all ready to go, but it's not. I have ove 400 movies & TV shows on my NAS, but I can't access them. Samba doesn't work and I don't have the skills or the time to mess with this.

Thanks, good try, but I'm just going back to Kodi. Plex is too complex for the average user.
 Reply
 
 
Forum Jump:

Users browsing this thread: 2 Guest(s)