Hello There, Guest! Login Register
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

PlexPi 1.2 Doesn't add files on HDD attached to the router

first of all thanks for this great release! I just bought a Pi3 to run my PMS so I'm not experienced with the pi and I have a limited linux knowledge.

I was able to access the plexpi web gui (although I need to use the IP address as the alias plexpi.local doesn't work).

I have a previously installed instance of PMS on my laptop and I have all my media on 2 HDDs both connected to the router.

On my laptop PMS I've configured the libraries to point directly to the network paths were the files reside, for example \\READYSHARE\HD1\MOVIES.

I tried to configure PMS on plexpi with the same path but it doesn't find the media.

Any clues?

EDIT: apparently I need to mount the network drive first, I manage to do it with the following commands (I have two HDDs):

mount -t cifs // /mnt/usb2TB
mount -t cifs // /mnt/usb1TB

How can I mount them automatically every time I reboot the pi?

I've tried adding to /etc/fstab the following lines but it doesn't work (my network share doesn't need password):

 // /mnt/usb2TB cifs username=root,password= 0 0 
// /mnt/usb1TB cifs username=root,password= 0 0

After some researches it seems that the mount command on the fstab is being executed before the network interface is up. In fact, if I manually run after the boot

sudo mount -a

the 2 HHDs get mounted correctly, so the line in fstab is correct.

Any clues on how to solve this?

I've solved it!! I run 

sudo raspi-config

and set in boot options to wait for network. I don't use the pi offline, so it's not an issue for me.

Hope this helps!!



:) Thanks for the play by play! Glad you got it figured out! Well done.
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
Forum Jump:

Users browsing this thread: 1 Guest(s)