Hello There, Guest! Login Register
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[FIXED] SD Card Bit the Dust and Cannot Get Online Backup

#1
Hello All,

The SD card in my NEMS Pi has gone south. Replaced it but now need the backup file which was unavailable. I have the Online Backup service but since I had no choice but to replace the card, I cannot see the previous backup files. I know I should have kept a local file just in case (bad on me) but is there a way I can retrieve the already existing backups on the server?

Thanks for any assistance!!
Thanks all,

Marshman  NY, USA
 Reply
#2
Hey Marshman,
Sure. The backups are there, you just have to authenticate against the service.

1) Is it the same Pi? If yes, you're golden. If not, you will need to let me know on Patreon what your new NEMS HWID is.
2) Enter your NEMS Migrator Off Site Backup Key into NEMS SST
3) Enter your encryption password into NEMS SST, ensuring it is the same as it was previously (otherwise you will not be able to decrypt the backup since the passwords won't match).

Keep in mind, once you add your NEMS Migrator Off Site Backup Key, it takes up to 24 hours to see it in the web calendar (next backup). But you should be able to see it with nems-restore. I'll improve this in a future release (make it instant), but for now, that's how it is.

Let me know if you're still stuck.
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#3
Thanks Robbie. I must have changed my password somewhere along the line because I am getting this:

Attempting decryption...


gpg: AES encrypted data
gpg: encrypted with 1 passphrase
gpg: decryption failed: Bad session key
Error with backup.

2018 has been a rough year so far. Sighhhhhhh.
Thanks all,

Marshman  NY, USA
 Reply
#4
BTW, same hardware. Just a new SD card.
Thanks all,

Marshman  NY, USA
 Reply
#5
Yep - that's fine. As you can see in nems-restore, you can see the backups (so your HWID hasn't changed). So you just have to adjust your encryption/decryption password to match whatever you entered in NEMS SST when you activated off site backup, otherwise NEMS Migrator will not be able to decrypt it.

Of course, this information is also only known to you, and I do not have any way to access it / retrieve it for you, as you know from my Patreon posts about how important it is to me to protect user's private data.

Let me know how it goes. Hope you can remember your password!
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#6
WOOO HOOOO! I kept a record of my old UID and PWD and the backup went through. However, these are the last few lines (see the lines in bold):

Consolidation complete.

NConf failed. Your NConf data is corrupt.
You should be able to re-create it.

I hope everything worked okay for you.
Please let me know if you had any trouble.

PS - I saved a backup for you of the old config. /root/backup.nems
... just in case
Thanks all,

Marshman  NY, USA
 Reply
#7
Hmm, I wonder why your NConf data is problematic. Can you re-run the restore and send the full output?
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#8
Also, after running the restore operation (and before rebooting) please send the output of this command:

ls -lah /tmp/nems_migrator_restore/var/www/nconf/output

If it says not found, try:

ls -lah /tmp/nems_migrator_restore/var/www/nconf

And if still not found, try:

ls -lah /tmp/nems_migrator_restore/var/www

Based on the error you have received, I have to ask: did you ever compile your config in NEMS NConf? The error means those config files can't be found - which should only happen if you did not compile in NConf. Listing the output folder contents as per above will confirm this.
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#9
Marshman - Forget everything I just said.

You found a massive bug.

https://github.com/Cat5TV/nems-migrator/...f31a4c0L71

When I added encryption, I made sure to remove any plain-text backups of any private info... such as resource.cfg, nems.conf or ... you guessed it ... /var/www/nconf/output

https://github.com/Cat5TV/nems-migrator/...f31a4c0L65

You'll see I added /var/www/nconf/config to the encrypted output, but neglected to include /var/www/nconf/output

I have fixed this .... https://github.com/Cat5TV/nems-migrator/...6bd497a3f6

All is not lost, but I may have to help with recovery.

Please login to NConf and see if you have access to your hosts as you should, or if it's empty. Let me know.

I'll move on to damage control mode now....

THANK YOU!
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#10
Sorry to keep finding bugs. Big Grin

My hosts are there and acessible. Kind of strange that even with the error everything seems ok.
Thanks all,

Marshman  NY, USA
 Reply
 
 
Forum Jump:

Users browsing this thread: 1 Guest(s)