Hello There, Guest! Login Register
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

SNMP help

Thanks Robbie,

Never doubted you!

No rush, as stated before - a nice to have - (back).

Hi Tech Dave.
Sorry for the long wait. Development for 1.4.1 has been intense (and amazing)!

I got tired of waiting for nagios-plugins 2.2.2 to release. It is still showing as only 86% complete and I can't see continuing to wait.

So I wrote a new compiler for you which compiles and installs nagios-plugins 2.2.1 for all the plugins, and then compiles check_snmp 2.1.1 from the good ol' days when check_snmp worked correctly :) So basically holding back that one check to the older version so you get the desired output.

Note: this will have the adverse effect of no ipv6 support for check_snmp. This will be fixed when 2.2.2 is released (I'll update the compiler). That's out of my hands.

**This must only be run on NEMS 1.4+. Running this on NEMS 1.3.1 or earlier will break things.

sudo /root/nems/nems-admin/build/051-nagios-plugins

This is my output after applying the patch:
/usr/local/nagios/libexec/check_snmp -H -c public -o
SNMP OK - Timeticks: (351383647) 40 days, 16:03:56.47 |

Note: it'll take a while :)

That should fix it for you. Could you please let me know?
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
Hi Robbie,

Sorry for the late reply - I have been out of town on one of those very rare and weird things called a 'vacation'.

Thank you for this - I'll try it out on one of my Secondary units and let you know.

Quote:Note: it'll take a while Smile

'It'll take a while' - getting to know you now Robbie - That was a whole coffee watching a beautiful compile build (excepting Depreciation Declarations which are expected) without any errors - well done Cool

I have seen less output on a Rack Cluster rebuild - Tongue

As ever Robbie, you are the NEMS Master AKA Bald Nerd - very impressive. NEMS just keeps getting better!!

Haven't see this for a while:

Current Status: OK  (for 33d 14h 29m 13s)
Status Information: SNMP OK - Timeticks: (751289200) 86 days, 22:54:52.00

Thank you so much Robbie - it makes my admin a whole lot easier with a overview of up time of all systems.

Tipjar coming your way.

Cheers, Dave. I appreciate the deposit to the tip jar, and I'm so glad to see my patch worked for you and achieved what you'd hoped for.

If anyone ever doubts I love my community, you set 'em straight Dave... you set 'em straight.

Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
Hi Dave,
NEMS 1.5 is about to release for Raspberry Pi, and since I've still seen absolutely *zero* movement on this bug fix from the Nagios team, I have decided nagios-plugins appears to be a dead project. Back in 2016 it was forked by the original dev team and they released it as monitoring-plugins. This fork (monitoring-plugins) continues to be actively maintained by its team and is miles ahead of nagios-plugins. So for NEMS 1.5 I have opted to make the switch.

This of course means undoing the patch I'd previously issued for you - however I would expect that since monitoring-plugins is active, they will have already fixed it.

Please test with NEMS 1.5 and let me know if you experience any trouble.

Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
Forum Jump:

Users browsing this thread: 1 Guest(s)