Hello There, Guest! Login Register
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Newbie having buffering issues on Plexpi

Hey DoowronDog,
Sorry for the delay. Are you 100% sure you're using a super fast SD card? Some of what I'm reading here sounds like a slow SD card.

Let me know.
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
No worries,

32gb Samsung EVO+ 1U microSDHC. Should be fast enough.

I found my pi was struggling a lot with .mkv files as it has to transcode them for various devices. However it played .MP4 files flawlessly since it seems to be a much more supported file type so in the end I ended up converting all my .mkv's to .mp4's and now no issues :)

Also i'm running my plexpi off a hard drive (same one that the films/tv is saved to) so don't know if that makes a difference?
Same issue here. Running the server on a Rpi3B. The client is an AppleTV4K. The .m4v video file is of fairly low 568p quality so data throughput should not be an issue. Tried running the video from an external 128GB Samsung thumb-drive, and also from the high speed micro SD card, but to no avail. After 3, 5 or even 20 minutes it stops playing and that's the end of it. Tried over WiFi and Ethernet (speeds of 150Mb+), still nothing. The OS itself is working fine, but the Plex application itself starts acting funny and not loading stuff. Running the same file from a Macbook Pro Plex server is fine, zero issues. Other than trying another Pi, I am kind of out of options here...
(04-09-2018, 03:19 PM)DoowronDog Wrote: Hello Robbie,

Thanks for the quick response. Please see the answers in red below.

2) What format / codec / bitrate are the files you're attempting to play?
I'm not too sure of how to obtain these settings; so theoretically I'm only using the default settings.
So far all I'm trying to do is watch live TV and a recording here and there. Both Live TV and recordings are performing the same way. I've also disabled Transcoding on the DVR/Tuner to further troubleshoot.

A quick method I use to check video file properties is using Get Info directly in Plex: select the "three dots" in the lower right of the movie poster and Get Info will be the last entry in the bottom of the list.

The MP4 codec seems to be faster streaming while the H264 requires transcoding, I believe.
As far as I know, the transcoding is dictated by the client. If the client is able to handle the codec, then no transcoding is needed (unless you need subtitles, they may lead to a transcoding regardless the codecs).

I'm using an unofficial (paid around 7€) app on my LG WebOs based telly. It's called XPlay and it's doing his job flawlessly. Almost everything doesn't need transcoding and, in case it does, the app tells you that clearly before playing the movie. I'm using subtitles so most of the time the transcoding happens because of that.

PlexPi is doing great for me, I'm only looking for a way to update the PMS without breaking everything!
So, it turns out the PlexPi is at fault and just simply isn't yet baked well enough to work well for everyone. Here's how I know.

I sat down yesterday and installed a new build of Raspbian on the same SD card. Then manually installed PLEX. Ran a file from the SD card, worked without issues. Added a 128GB Samsung USB stick, formatted to EXT4, ran a file off it, worked like a charm. I went even further and installed a Samba server so that it would have NAS capabilities as well, mapped some internal storage, some external storage (all EXT4), everything working without issues. Sure, it takes a bit of time to set it all up, but it's worth it.

Sorry guys, the Plexpi needs a bit more baking... Wink
I to am having serious buffering issues.  Running plexpi on a raspberry pie 3b+, wired in to my network with a high end NAS 4 gig hardrive attached.  Tried mkv files but had serious buffering issues.   Converted them all to mp4 files on a standard quality and still tons of buffering.  Please, please help!  Any idias?????
Same buffer issue's here, local and outside buffer problems.
I use an Raspberry Pi 3B+ and have a Asus RT-AC68U.
Also on low video's SD like .mp4 720x576 pixels.

Is there an issue with an Pi 3B+?

What I've experienced is I was getting buffering only if the hard drive is directly connected to the USB drive. If it's mounted via network it's working fine (of course if no transocde is needed).
Same files, same hard drive. This is weird because I'd have expected the opposite. Is your hard drive plugged to the USB or shared via network?
Forum Jump:

Users browsing this thread: 1 Guest(s)