Hello There, Guest!  
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Newbie having buffering issues on Plexpi

#1
So I've been experiencing some bad buffering issues when using the plexpi v1.3 on a new Raspberry pi 3 B+; and I'm hoping someone can assist. Please see some details about my home network below.
------------------------------------------------------------------------------------
1: Internet Connection: FiOS 75/75
2: Router: Older Wireless N Netgear Router (This is being replaced today)
3: QoS Upstream Maximum: 75 mbps
4: Raspberry pi is connected directly to the router and WiFi has been disabled.
5: HD Homerun Connect DUO TV Tuner (Directly Wired with Transcoding enabled).
6: I believe "Direct Connect" is also disabled in the Plex server settings.
7: All Plex clients at this point in time are connecting to the server via WiFi (I plan on directly wiring the TV when I return home tonight).
-------------------------------------------------------------------------------------
I guess the question is this:
Could I be seeing a bottleneck with the Raspberry pi or do you think that it is the older router causing the problem?

Even when I have my settings configured for the lowest quality I continue to see a consistent buffering issue which is making the content un-watchable.

Thanks in advance for any suggestions.
 Reply
#2
Of particular interest would be:
1) When you play the files DIRECTLY on the PlexPi server (eg., plug it into a TV), do they play fine?
2) What format / codec / bitrate are the files you're attempting to play?

That's step one to diagnosing this for you :)

Cheers,
Robbie
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#3
Hello Robbie,

Thanks for the quick response. Please see the answers in red below.

1) When you play the files DIRECTLY on the PlexPi server (eg., plug it into a TV), do they play fine?
I'm actually going to be connecting it directly to the TV tonight; so I can test that and post my findings. 

2) What format / codec / bitrate are the files you're attempting to play?
I'm not too sure of how to obtain these settings; so theoretically I'm only using the default settings.
So far all I'm trying to do is watch live TV and a recording here and there. Both Live TV and recordings are performing the same way. I've also disabled Transcoding on the DVR/Tuner to further troubleshoot.
 Reply
#4
Alright, let me know re. #1.

Remember, when you "turn down" the quality setting, you are forcing the Pi to re-encode the file to that lower bitrate. That means high CPU usage on that little guy.

To find the info about your files, go to terminal on your PlexPi and type:

sudo apt update && sudo apt install mediainfo

That'll install the tool you need (which I will be mindful to include on a future release).

Then, let's pretend your file is located at /media/harddrive/file.mp4 type: mediainfo "/media/harddrive/file.mp4"

Of course, replacing the section in the quotes with the actual location and filename.

If you're stuck, let me know. As PlexPi evolves I will make this kinda stuff easier.
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#5
I'm having buffering issues, too, but  only when directly connecting my TV to the PI via HDMI.

I decided to move the PlexPi to my media center and connect  it - a PlexPi (3B+) - to my Samsung Smart TV (UN55H6300)   with an Amazon Basics HDMI cable.  I loaded a tv show and performance was  bad:  the Pi seemed to buffer every 15 - 30 seconds.

I then loaded the Samsung Plex agent onto the Smart TV and now find that things are now playing fine.  

FWIW, the PlexPi and the Samsung are located on the same gig switch so there shouldn't be any bandwidth problems there.

I watched a more TV programs and had the programs quit occaissionally (showing network errors) but that was after 25 to 40 minutes of flawless performance.  Fast Forward and Rewind worked great.  

I'm wondering if either the Pi's  GPU isn't up to the task or, perhaps, allocating more RAM on the Pi might eliminate the buffering.
 Reply
#6
Ok so I directly connected the pi to my TV and it straight up froze when trying to play a video that had been previously semi recorded. I then tried resetting everything back to defaults in Plex which didn't yield any positive results.
I've also installed a brand new router (Netgear AC1750) and connected the TV, pi, and the HD Homerun Connect Duo tuner. However I'm still seeing the same results.

I Installed the recommended mediainfo app but upon browsing the drive I realized that there hadn't been a single file written for recordings.

Longer story short I ended up blowing away the entire image and starting from scratch (with a re-image using Etcher). This didn't help and I'm still having major issues with streaming and recording..

Part if this is that fact that I have zero experience with Raspberry pi systems and I don't understand how to to make it work efficiently.
 Reply
#7
Robbie,

I'm going to give this another go tonight as I know there's got to be something I'm missing in the streaming configuration; and I don't want to abandon this project/adventure just yet. But in the meantime do you have any suggestions as far as what the correct settings would be based on the info I've already provided? I'll also make another attempt at obtaining a successful recording to grab the info using the utility you've recommended.

I've not configured any QoS settings on the new router as I was able to get an old Windows laptop running w/o major issues; thus I really feel that it's a configuration setting on the PlexPi itself. 

Thanks in advance for any feedback!

-Scott
 Reply
#8
The videos I'm recording via the DVR are being saved as ".ts" files. I should've also been clear in my original post that I have not loaded any other content onto my external drive to test as of yet. 

I've actually gone back to my other setup with my laptop; which has been performing at a higher success rate for streaming for now. I've also found that the majority of the issue I had been seeing is due to just not having enough processing power to convert incoming recordings on the fly (which is definitely a bummer until I purchase a higher end system). another issue is with the app on ios 11.3. Since switching back to the laptop I haven't had any streaming issues with my other devices. I may just have to await an update for the iOS app.

So I've abandoned the Plexpi project for now (My wife really wants to use our new media room and has become frustrated with not having a DVR). I'm guessing that my media server requirements out-weigh what the Raspbery pi hardware is capable of. Guess I'll be re-purposing it to a RetroPie for now.  Smile

Thank you for the assist. It is greatly appreciated.

-Scott
 Reply
#9
Hi all,

First off thanks for an amazing way to run Plex on the pi. I'm also running into buffering issues as well. I run the pi with 2 extenal hard drives attached. I stream the media with either a Chromecast or using my fire TV. Both methods have issues with buffering, however the fire TV gives me a message saying the server is not powerful enough to run this media smoothly. Just wondering if anyone else has seen that message yet? Thanks again for all the work.
 Reply
#10
Absolutely. It is a great build; but I had the same issue. I also see it on my current system and that has a more powerful processor. I think it really comes down to what type of content you’re streaming; as well as your connection to the server. Patience and tweaking of your settings are crucial elements to finding an acceptable experience. Start by setting quality to maximum and work down from there. Good luck.
 Reply
 
 
Forum Jump:

Users browsing this thread: 2 Guest(s)