Hello There, Guest! Login Register
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

trends and histogram not working in 1.4 new install

#1
Hello,

I'm new to the forum and NEMS, just got a new install of 1.4 on a PI v3. It all seems to be working well and I have my inventory of hosts and service checks added, but I get the below error when I access the trends or Alert Histogram from the host detail screen within the NEMS Nagios Core UI.  All other links in the list (Status Detail, Alert History, etc) are working fine, yet pointing to cgi files rather than html.

I didn't see it in the known issues log, so hopefully someone can help.

Thanks,

Damon


Not Found
The requested URL /nagios/trends.html was not found on this server.

NEMS_Linux/1.4 Server at 192.168.200.140 Port 443

-or-

Not Found

The requested URL /nagios/histogram.html was not found on this server.


NEMS_Linux/1.4 Server at 192.168.200.140 Port 443
 Reply
#2
Welcome to NEMS!  :)

Thanks for reporting the issue. I'll investigate this and get back to you. A couple more pressing bugs today - but I'll try to be reasonably quick!

BTW - the known issues page kinda fell behind since NEMS 1.4 was just released... so some of the issues are from 1.3.x, and I have to re-write the page... but I added this to it for you, and will be working on that soon.  :)

Robbie
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#3
Hi, new to NEMS but has successfully installed 1.4.1 on a RPI 2 and monitoring 15 hosts.
Most things are working great except reporting and graphing where I get the same messages as you. Did you ever resolve your problem?
 Reply
#4
@Ksvard - I haven't seen any update to this issue, still acting the same on my 1.4.1 system.
 Reply
#5
Hey guys,
This was fixed and patched long ago. Have you edited core files, thereby causing the updates to not be allowed on your systems? For example, if you manually edit files in /var/www/html, you will no longer receive updates to /var/www/html as those updates would override your changes. This would also cause you to not receive updates to the Nagios interface, which is part of nems-www.

Just a guess. But again, this was patched long ago so what you're seeing is an unpatched system.

Let me know - happy to help you diagnose.
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
 
 
Forum Jump:

Users browsing this thread: 1 Guest(s)