Hello There, Guest! Login Register
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Fresh install of latest version - nems-mailtest not working

#1
I installed NEMS 1.4.1 on a Raspberry Pi 3 B+ today. Without any changes, right out of the box I filled the SMTP Email Configuration an ran the nems-mailtest.
This is what I got:

Please wait...sh: 11: ** -m *****: not found
sh: 13: Notification: not found
sh: 14: Host:: not found
sh: 16: Address:: not found
sh: 19: Date/Time:: not found
sh: 20: Syntax error: Unterminated quoted string
Jul 11 18:56:36 nems sendemail[5570]: WARNING => The argument after -xp was not valid password!
Jul 11 18:56:36 nems sendemail[5570]: ERROR => You must specify a 'from' field!  Try --help.

Is this a bug, or did I make a mistake?
 Reply
#2
Could you please try running: sudo nems-quickfix

Just to rule out that you're using an obsolete version of nems-mailtest.

If it still doesn't work, can you email me an unencrypted copy of your backup.nems file to review?

Thanks,
Robbie
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#3
Hi Robbie,
after running the quickfix I still got the same error. I then saved my settings again without changing them and now it is working.
Thanks a lot for your help.
Best regards
Arwed
 Reply
#4
Well, I'm glad to hear it's working now!! Something must've got mixed up with your config file ... so saving again would have re-created it.

Thanks for the update! Enjoy!

Robbie
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#5
Hi Robbie,

Running into a similar issue on a new install (NEMS 1.4.1- RPI3B+) even after applying nems-quickfix:

Please wait...

sh: 10: 6.7/: not found
Sep 09 19:42:19 nems sendemail[11315]: ERROR => You must specify a 'from' field!  Try --help.

Update:

Downloaded and flashed NEMS image on a fresh SD card; same issue.
 Reply
#6
Thanks SFM. Can you please send me your support.nems file so I can review? I've yet to see an affected support.nems file, and have not been able to replicate it with my own settings.

Also, in that private email please paste the entire output of the terminal including what you typed to initiate nems-mailtest.

Also, I just pushed out a patch that allows apostrophes and quotes in SMTP passwords. So if you have either of those, please do a nems-update and then try again to see if that's all it was.
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#7
Hi Robbie,

The update worked, since I did have a semicolon in the password.

Thanks for your help, you can ignore my email  Smile
 Reply
#8
Okay awesome. I'm pretty confident then that this will also fix it for arwed. I do my best to think of every scenario when I write the code, but sometimes little things like that creep up. Thanks for letting me know!
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#9
I realize this post is several months old.  My primary use for NEMS/Nagios will be for notification.  Can't get nems-mailtest working.  Returns:  
Please wait...
Message could not be sent.
Mailer Error: SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/w...leshooting

Verified SMTP settings, I can ping the destination SMTP server, verified e-mail credentials.  Output from message isn't too helpful.  Having trouble finding out what exactly is going on (which I had more verbose debugging output).  Tried nems-quickfix and nems-update.  No joy...  Any ideas?

Brian
 Reply
 
 
Forum Jump:

Users browsing this thread: 1 Guest(s)