Hello There, Guest! Login Register
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Error in /usr/local/nagios/libexec/check_nrpe: corrupted size vs. prev_size: 0x015d9d

#1
Hi , I've been trying to get nems4 running on a pi3. I've set up monitoring an ubuntu server's root disk & I keep getting e mails with :-


Service: Check the root filesystem disk space

Host: stpb
Address: 10.YY.XX.ZZ  ( I've removed the i/p)
State: UNKNOWN
 
Date/Time: Thu Jul 12 13:52:23 BST 2018
 
Additional Info:
 
(No output on stdout) stderr: *** Error in /usr/local/nagios/libexec/check_nrpe: corrupted size vs. prev_size: 0x015d9d58 ***


I've managed to find the command it runs on the pi as 'check_nrpe' & when I run it against different hosts from the pi's command line
I get the same message


/usr/local/nagios/libexec/check_nrpe -H 10.YY.XX.ZZ-c who ( get the same with any command, ie 'ls')

*** Error in `/usr/local/nagios/libexec/check_nrpe': corrupted size vs. prev_size: 0x00731da8 ***


The '/var/log/syslog' on the target system gives

Jul 12 13:19:23 stpb nrpe[26765]: Error: Request packet type/version was invalid!
Jul 12 13:19:23 stpb nrpe[26765]: Client request was invalid, bailing out...


Does this indicate that the 'check_nrpe' is corrupt ??
#2
Not really found a fix, just a work round 'sudo nems-init'
#3
Hi steve74,
Not sure what you mean about running nems-init. That is a required process to activate your NEMS server. Before initializing it, you cannot configure it.

Have you resolved your issue? I'm not 100% clear on what it is you're experiencing. The error message could point to an old version of NRPE on the target system, but again, I'm not sure what you're describing as you haven't really told us about your setup. :)

Cheers.
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 
 
Forum Jump:

Users browsing this thread: 1 Guest(s)