Hello There, Guest! Login Register
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

upgrading to Nems 1.4

I have been away for some time overseas so I have just had a chance to upgrade to Nems1.4. I backed up my Nems 1.3 configuration to a USB drive. I then installed Nems 1.4.1 on to a 16GB micro SD card. I also decided to run Nems 1.4 on a Raspberry Pi 3B+. I put micro SD card into Raspberry Pi 3B+ and powered up. It boot up and I pressed Ctrl + Alt _F2 and got login prompt. I logged in and ran sudo nems-init and all went OK. I then mounted USB with backup.nems on it and ran sudo nems-restore /mnt/usb/backup.nems. The restore worked with no problems. I rebooted Raspberry Pi and everything worked OK and all my config dta was there. I then went to webadmin and saw there were 99 updates waiting. I updated all 99, it said completed and to reboot Pi. I rebooted but now I get following message at end of boot up:-

You are in emergency mode. After logging in, type "journalctl -xb" to view system logs, "systemctl reboot", "systemctl default" or ^D to try again to boot into default mode.

Cannot open access to console, the roor account is locked. See sulogin(8) man page for more details.

Press enter to continue.

I have pressed enter but received exactly same message as above. I have tried several attempts using different key combinations during boot up without any success.

Is there any way out of this or do I have to start from scratch again?
Gazza Cool
Hi Gazza,
Please re-flash NEMS 1.4.1 and import your backup.nems again, but this time do not install the [possibly unsupported] updates. I must reiterate, NEMS automatically patches itself against security exploits. There is generally no need to run an apt upgrade / apt dist-upgrade unless you don't mind breaking things :)

webmin is a great utility, but the "warning" of pending updates can be misleading. Those are OS updates and not related to NEMS. I can't promise they won't break things, so it's best to wait until they're tested (and will be updated in a future release).

No harm in breaking things. That's why you have Migrator - easy to recover.

Welcome back! Hope you enjoy NEMS 1.4.1!

Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
Thanks Robbie that certainly solved my problem. I put image on new 16GB card and initialised it and now everthing is working OK. 
Just one question - is it possible to change the default backup location for NEMS Migrator Backup Service?
Gazza Cool
No. Migrator snapshots are stored in the 'snapshots' location, which is in RAM (not on the SD card). There are many ways you can sync it to another location though. Please see the documentation for ideas. There is a 'backup' share at \\nems.local / smb://nems.local, plus you can get the file via an authenticated https: request with wget/curl/etc. If those don't meet your needs, perhaps tell me what it is you're actually hoping to do and I'll either explain how it can be done, or modify the system in a future release (if needed).

Glad the re-flash fixed your issue!

Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
Forum Jump:

Users browsing this thread: 1 Guest(s)