Hello There, Guest! Login Register
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Upgrade to nems 1.5 nagios.service issue

Testing upgrade to nems 1.5 and getting a restore error then failure of nagios livestatus.

Imaged new sd card, backed up existing 1.4.1 instance.
Nems-init on new sd card (same user name used as backup).
Nems-restore the backup.
Everything runs fine through "Consolidation complete." (all the imports appear to have worked).
Then get two lines :
   "Job for nagios.service failed because the control process exited with error code" (yes, that's all, no error code).
   "See "systemctl status nagios.service" and "journalctl -xe" for details."

Looking at systemctl, get this:
\cglcs@nems:~ $ sudo systemctl status nagios.service
● nagios.service - Nagios Core 4.4.3
   Loaded: loaded (/lib/systemd/system/nagios.service; disabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sat 2019-02-23 10:41:59 MST; 1min 24s ago
     Docs: https://www.nagios.org/documentation
  Process: 16417 ExecStartPre=/usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg (code=exited, status=1/FAILURE)

Feb 23 10:41:59 nems nagios[16417]:      Check your configuration file(s) to ensure that they contain valid
Feb 23 10:41:59 nems nagios[16417]:      directives and data definitions.  If you are upgrading from a previous
Feb 23 10:41:59 nems nagios[16417]:      version of Nagios, you should be aware that some variables/definitions
Feb 23 10:41:59 nems nagios[16417]:      may have been removed or modified in this version.  Make sure to read
Feb 23 10:41:59 nems nagios[16417]:      the HTML documentation regarding the config files, as well as the
Feb 23 10:41:59 nems nagios[16417]:      'Whats New' section to find out what has changed.
Feb 23 10:41:59 nems systemd[1]: nagios.service: Control process exited, code=exited status=1
Feb 23 10:41:59 nems systemd[1]: Failed to start Nagios Core 4.4.3.
Feb 23 10:41:59 nems systemd[1]: nagios.service: Unit entered failed state.
Feb 23 10:41:59 nems systemd[1]: nagios.service: Failed with result 'exit-code'.

When I start the web interface I am able to get to the front end, but going to any of the reporting tools generates "livestatus" errors.

Any assistance would be appreciated, and let me know what I can do to help.

Thanks, Steve
Hello hudtheitguy,

i had a similar problem restoring a 1.4.1 backup on a fresh installation of 1.5 build 2 which got very fast "fixed".

Have you allready tried creating a new nagios config in "nconf"?

There i got an error which told me that there a contact is missing for successfully creating the new nagios config. So i created a contact and after this i was also able to create a new nagios config.

And nagios is now working properly again Smile
Very interesting. I went and generated a new config, didn't get any errors and deployed it.  Then I went back to reporting pages (Adagios, mobile and TV) and no errors there. Doing the initial config and deploy appears to have solved this.  I never got that far since I was getting errors in the restore and also in the reporting pages. I am going to do another fresh install and see if I can replicate this result.

Thanks IMBACalimba, appreciate the pointer!

I went ahead and started from scratch.  Flashed an sd card, did initial init, restored nems.

The same failure message appeared during the restore.  And when I first logged into nems, the reporting pages didn't work.

Went over to nconf and generated a config (no changes to anything, just generated a config) and deployed.

Everything working.

If I had to guess; there is something in my cfg files that the new version of Nagios doesn't like, but is fixed when a config is generated with the new version.

And just to finalize this. I went ahead and backed up my now working nems 1.5 instance; flashed yet another sd card with nems 1.5; initialized and restored the backup. All working as expected with no issues.

So in summary; there was likely something in my cfg files from nagios in nems 1.4 that the nems 1.5 upgraded nagios was having none of until a new config was run. After that, everything works as expected.

Forum Jump:

Users browsing this thread: 1 Guest(s)