Hello There, Guest! Login Register
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Errors when trying to use services

#1
Hi,

I have setup NEMS Linux and I am using it to monitor some servers at work.

I can successfully use the service PING for all of my servers, however, when I want to use other services to check the root partition or the CPU load for example, I get an error. For the 'Check the root filesystem disk space', I get the error NRPE: Command 'check_disk -w 80 -c 90 -p /' not defined

And for the CPU load, I get the following error:

connect to address <CLIENT_IP> and port 12489: Connection refused
could not fetch information from server


Also, when trying to use the service 'Check ROOT Partition' for all of my servers it shows the exact metrics as for my NEMS server:
SERVER A
DISK OK - free space: / 11045 MB (74% inode=87%):

NEMS SERVER
DISK OK - free space: / 11045 MB (74% inode=87%):

I have installed the NRPE agent on my client's server and ran the command from my NEMS server and showed NRPE v3.2.1 
/usr/local/nagios/libexec/check_nrpe -H <CLIENT_IP>

I am completely brand new to Nagios and NEMS so apologies in advance for my lack of knowledge.

Any help would be truly appreciative. 
 Reply
#2
Hi Marc

Please check if the port is open on your target server (Port 12489) ( Telnet is useful for that)

Which version of NEMS Linux, which build, and which platform?

Levin | Premium
 Reply
#3
Hi,

Port 12489 is opened, when I run ufw status verbose, it confirms that port 12489 is opened and will ALLOW IN from Anywhere, and I still receive...

connect to address <CLIENT_IP> and port 12489: Connection refused
could not fetch information from server


for the CPU Load service check.

My setup is...

NEMS Platform....: RPi 3 Model B+
NEMS Version.....: 1.5 (Current Version is 1.5)
 Reply
#4
At quick glance it looks as though you may not have configured the checks (NRPE) on the servers you are trying to monitor. Could this be the case?

Also, applying the NEMS local check which tests the disk space of the NEMS server makes no sense to add to another server. As you noted, you're getting the output of the NEMS server, not the host you applied it to. Think: "Ping Google and tell me if it's up" - then, add that check to say, yourdomain.com. Makes no sense... you're still pinging Google. So instead, you need to create checks for YOUR server's root filesystem, not the NEMS server.

Robbie
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
 Reply
#5
Hi Robbie,

Apologies for the late reply.

Are there any good documentation on how to configure the NRPE for NEMS please?

Thanks.
 Reply
#6
As you can see, I am allowing port 12489 but still get the same error "connect to address 10.1.206.144 and port 12489: Connection refused"

ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:12489

ACCEPT     udp  --  anywhere             anywhere             udp dpt:12489
 Reply
#7
Open the path in windows C:\Program Files\NSClient++\  . And there open the file nsclient.txt.
This is a log file ,can you spot any errors there


Greetings

Levin | Premium
 Reply
 
 
Forum Jump:

Users browsing this thread: 1 Guest(s)