Hello There, Guest! Login Register
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

ESXi Hardware-Version of NEMS OVA

I'm facing the Problem, that the OVA-File for vSphere is built on almost the latest Hardware Version of ESXi (Version 14 https://kb.vmware.com/s/article/2007240?lang=en_US)
This makes the Appliance is not Usable out of the box on my ESXi 6.0.
Since all ESXi-Servers provide backward compatibility to older harware versions I recommend to Build NEMS on Hardware-Version 10 (Witch is Supported from ESXi 5.5 and newer) so the applicance can be used on a wide spectrum of hypervisors.

I was able to "Downgrade" the appiance to Hardware Version 10 with following method:
  1. Unzip the .OVA-File with 7zip
  2. Edited the .OVF-File with Atom
    Line 31 before:<vssd:VirtualSystemType>vmx-14</vssd:VirtualSystemType>Line 31 after:<vssd:VirtualSystemType>vmx-10</vssd:VirtualSystemType>
  3. Rewrote the NEMS.mf (Manifest) with OpenSSL
  4. Imported the Appliance in the VMware Workstation 15 Pro and booted it once for testing.
  5. Exported the de vmdk
  6. Created a new VM, using the vmdk as disk.
  7. NEMS booted without any issue on ESXi 6.0
In some Cases you may also need to change other minor incompatibilities.
Thank you for letting me know how you remedied this.

With NEMS Linux 1.5 being Debian Buster-based, ESXi has a weird quirk when creating the VM: Buster is not an option unless you select the latest version.

I tried building against an older version, but it failed.

But if your process remedies it and runs well, I will gladly implement the same "fix" and release another build.

How has it been running?
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
It is running well on the old ESXi... No hickups yet.

Since NEMS is headless and won't need the latest VMware Tools, you simply could "lie" to ESXi on Machine-Creation and select a lower Version of Debian. (I choose Version 8.x the last time i was setting up Debian Buster on ESX 6.5)

Another (simpler) workaround is, to extract the .vmdk, upload it to the desired datastore and simply swap the Virtual Harddisk. (Does only work if the SCSI-Controller is the same)
Thanks. Since it's for distribution, I will try to "lie" to it, as you say. :) You must have selected Stretch or something?
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
It doesn't really matter what version of Debian you are selecting, as soon you are selecting the x64 Version. VMware will use KVM to accelerate the virtualization. This should be supported by a wide spectrum (I think it's Wheezy or newer) of debian-versions.
If you install VMware Tools (https://kb.vmware.com/s/article/1018414) or Open VM Tools (https://docs.vmware.com/en/VMware-Tools/...341D1.html), you could profit from some betther diagnostics and VM-Handling by the ESXi, but may make the VM less usable in other Hypervisors like MS Hyper-V or VirtualBox. So you'll may include the installation of those tools in the NEMS-Initialisation script.
walkerit, it turns out the reason Build 2 wouldn't compile against older hardware versions is because of a bug in the ESXi 6.7 interface. I encountered it again when trying to create Build 3, but decided to keep trying rather than accept the error. Logging out of ESXi, refreshing the browser, and logging back in allowed me to compile NEMS Linux 1.5 against version 7 hardware! I just had to "lie" as you say, and tell it I was building Debian 6 :D

So, Build 3 is around the corner. Final build should be ready this week, and I'll be releasing it this month, after more testing.

Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
is there a way you can upload an OVA directly? I dont have vmware workstation so i dont know how to deploy it directly to a vmware server 6.0

@luisolavarrieta That won't work, because the ESXi will simply not go further, because it doesn't support the requested hardware.
Try following: Extract the VMDK from the OVA by 7zip and try attatching it to a pre-existing VM. This also worked for a friend of mine.
Else: The free Trial-Version of VMware Workstation will do the trick too.
Forum Jump:

Users browsing this thread: 1 Guest(s)