Hello There, Guest! Login Register
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Weird Notifications

#1
I have just moved from 1.4.1 to 1.5. on the weekend.
I imported my previous settings/configs

I have tested my email with nems-mailtest successfully.

Today I decided to test a real time outage so brought down my brother printer MFC-L2703DW.

On my hosts I HAD notifications set to d,u,r,f,
I only noticed the "," at the end just now and have changed it to d,u,r,f,s

BEFORE I CHANGED (and after I changed)

I did not get any

down
up
recovery

notifications but did get a Flapping Notification / email so that proved my email was working in my view

I have my 

Max check attempts = 5
check interval = 15
first notification delay = 5
notification interval = 120

Notification enabled = 1

If I understand this I should get a first notification email 5 minutes after device goes down and another 120 minutes after that if devices is still down.

And when it comes up I should get a notification almost immediately.

This is the way it used to work under 1.4

Why am I only getting the flapping notification?


Weird
RT
 Reply
#2
Testing today 
I set up a Downtime for a printer and got the email notifications for start and end to downtime.
I also am getting Flapping email notifications.

I am just not getting any notifications for hosts

d
u
r

These are the ones I want ASAP after the event.

Any clues Robbie???

Cheers
Ron
 Reply
#3
more testing
------------------

This morning I brought down my Raspberry Pi TV server and waited to see what the results were.

I had set the notification period as 3 minutes.

I waited for a minute or 2 after bring down the server and had not indications in either NEMS TV or Adagios so thought I would force a check.

This is the log from Adagios....

2019-06-26 08:00
HOST ALERT
[/url]

tv-hat1;DOWN;HARD;5;CRITICAL - Host Unreachable (192.168.0.14)
2019-06-26 08:00
livestatus


TIMEPERIOD TRANSITION: workhours;0;1
2019-06-26 07:59
HOST ALERT


tv-hat1;DOWN;SOFT;4;CRITICAL - Host Unreachable (192.168.0.14)
2019-06-26 07:58
HOST ALERT


tv-hat1;DOWN;SOFT;3;CRITICAL - Host Unreachable (192.168.0.14)
2019-06-26 07:57
HOST ALERT


tv-hat1;DOWN;SOFT;2;CRITICAL - Host Unreachable (192.168.0.14)
2019-06-26 07:55
HOST ALERT


tv-hat1;DOWN;SOFT;1;CRITICAL - Host Unreachable (192.168.0.14)
2019-06-26 07:55
EXTERNAL COMMAND


SCHEDULE_FORCED_HOST_CHECK;tv-hat1;1561499746


OK so now I acknowledge the device showing up in Adagios and YES I get an email to advise me....

BUT NO DOWN EMAIL!!!

WHY?

Frustrating!!

Now I bring up the host 

here is log again No UP notification.

2019-06-26 08:15
HOST ALERT


tv-hat1;UP;HARD;1;PING OK - Packet loss = 0%, RTA = 0.57 ms
2019-06-26 08:10
HOST NOTIFICATION


nems21hl;tv-hat1;ACKNOWLEDGEMENT (DOWN);notify-host-by-email;CRITICAL - Host Unreachable (192.168.0.14);nems21hl;I know about it
2019-06-26 08:10
EXTERNAL COMMAND


ACKNOWLEDGE_HOST_PROBLEM;tv-hat1;1;1;0;nems21hl;I know about it
2019-06-26 08:00
HOST ALERT


tv-hat1;DOWN;HARD;5;CRITICAL - Host Unreachable (192.168.0.14)
2019-06-26 08:00
livestatus


TIMEPERIOD TRANSITION: workhours;0;1
2019-06-26 07:59
HOST ALERT


tv-hat1;DOWN;SOFT;4;CRITICAL - Host Unreachable (192.168.0.14)
2019-06-26 07:58
HOST ALERT


tv-hat1;DOWN;SOFT;3;CRITICAL - Host Unreachable (192.168.0.14)
2019-06-26 07:57
HOST ALERT


tv-hat1;DOWN;SOFT;2;CRITICAL - Host Unreachable (192.168.0.14)
2019-06-26 07:55
HOST ALERT


tv-hat1;DOWN;SOFT;1;CRITICAL - Host Unreachable (192.168.0.14)
2019-06-26 07:55
EXTERNAL COMMAND

[url=http://nems.local/adagios/status/log?type=EXTERNAL%20COMMAND]
SCHEDULE_FORCED_HOST_CHECK;tv-hat1;1561499746


What gives?
 Reply
#4
Today 

out of desperation I decided to delete and recreate a host that I was monitoring.

Success!!!

I cannot explain it but my guess is that the import was not quite successful.

So I then went ahead and cloned all my other 19 hosts and rebuilt the database for Nagios\.

I also modified the Max Check attempts, check interval , retry and first notifications delays so that I did not have to wait so long as I can always adjust these once I get it working.

So I now have my down, up emails again!

Cheers
RT 
 Reply
 
 
Forum Jump:

Users browsing this thread: 1 Guest(s)