Hello There, Guest! Login Register
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

NEMS won't resolve hostnames defined in the DNS of our Windows 2012 R2 server

Background (my experience with NEMS):
I'm relatively new to NEMS (i've set it up 2 or 3 times now) and I am in the process of using it in a real production environment.

Background (our issue):
Like most environments a bunch of our machines have been given hostnames in dns (type = HOST(A)). For example, our domain controllers are called DC01, and DC02 respectively. Needless to say these machines are reachable by their hostnames from windows machines on our network.

Our Issue:
None of these hostnames are resolvable on our NEMS deployment. If you define the host with the IP address in NEMS it works fine, but if you use the DNS name (for example DC01) it is not reachable. We obviously want to use DNS names in NEMS to define our host objects because their IPs could change in the future and that would require a complete reconfiguration of NEMS.

NOTE: one reason this is such an issue for us is because we already have a major network restructuring in the works and anticipate our whole IP scheme could change.

Thank you for your work and support.

Attached Files Thumbnail(s)
Hi there,
So are the hostnames setup on an in-house DNS server? Or just DNS entries in host files?

If you type:
nmcli dev show | grep DNS

I think you'll find your NEMS server is using DNS from an outside service (ie., Internet DNS, not LAN). Is that the case?

So would changing the DNS to your in-house DNS server be the answer?
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
Thanks for your reply Robbie.

Yes, the hostnames are set up on an in-house server - defined on our Windows 2012 R2 server.

I ran "nmcli dev show | grep DNS" on my Raspberyy Pi 3 running NEMS 1.2.3, but the command was unknown. I had to "sudo apt-get install network-manager" first, but the command returned nothing at all.

Fortunately there are other ways of figuring out the active DNS.

When I run "nslookup google.com" (or any other location - including hostnames defined on our DNS server) I get "Server:" - which is our Windows 2012 R2 box providing DNS services on our network.

Also, if I run the following:
cat /etc/resolv.conf |grep -i '^nameserver'|head -n1|cut -d ' ' -f2

I get "" - our DNS server.

Very strange.

But ping "dc01" - the hostname for our dns server returns "ping: dc01: Temporary failure in name resolution". Pinging "dc01.fmk.local" returns "ping: dc01.fmk.local: Name or service not known"

Very, very strange.
How many computers in your LAN? A very quick and dirty fix is to add them manually to /etc/hosts - but that's really only practical for small networks where you won't be changing IP addresses often.

What is returned when you type:
nslookup dc01

If it returns incorrect information, the problem is on your DNS server. If it returns correct information, NEMS is talking to the wrong DNS server.

I've also written this documentation in the NEMS wiki for you, just in case it helps: https://docs.nemslinux.com/usage/resolvi...mes_on_lan
Robbie Ferguson // The Bald Nerd

Did I help you out? Appreciate what I do? Please consider saying thanks:
Forum Jump:

Users browsing this thread: 1 Guest(s)